rubygem-cairo.SlackBuild 3.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132
  1. #!/bin/bash
  2. # Slackware build script for rubygem-cairo
  3. # Copyright 2015 Dugan Chen Canada
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=rubygem-cairo
  24. VERSION=${VERSION:-1.17.5}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. SRCNAM=cairo
  29. if [ -z "$ARCH" ]; then
  30. case "$( uname -m )" in
  31. i?86) ARCH=i586 ;;
  32. arm*) ARCH=arm ;;
  33. *) ARCH=$( uname -m ) ;;
  34. esac
  35. fi
  36. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  37. # the name of the created package would be, and then exit. This information
  38. # could be useful to other scripts.
  39. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  40. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  41. exit 0
  42. fi
  43. TMP=${TMP:-/tmp/SBo}
  44. PKG=$TMP/package-$PRGNAM
  45. OUTPUT=${OUTPUT:-/tmp}
  46. if [ "$ARCH" = "i586" ]; then
  47. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  48. LIBDIRSUFFIX=""
  49. elif [ "$ARCH" = "i686" ]; then
  50. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  51. LIBDIRSUFFIX=""
  52. elif [ "$ARCH" = "x86_64" ]; then
  53. SLKCFLAGS="-O2 -fPIC"
  54. LIBDIRSUFFIX="64"
  55. else
  56. SLKCFLAGS="-O2"
  57. LIBDIRSUFFIX=""
  58. fi
  59. set -e
  60. rm -rf $PKG
  61. mkdir -p $TMP $PKG $OUTPUT
  62. cd $TMP
  63. # Get the full path of the ruby installation, for gems
  64. DESTDIR=$( ruby -r rbconfig -e '
  65. include RbConfig
  66. printf("%s/%s/gems/%s\n",
  67. CONFIG["libdir"],
  68. CONFIG["RUBY_INSTALL_NAME"],
  69. CONFIG["ruby_version"]
  70. )
  71. ')
  72. # print a friendly warning of unsatisfied ":runtime" dependencies
  73. # good to leave in place, even if the gem doesn't have any dependencies.
  74. # things could always change
  75. gem specification $CWD/$SRCNAM-$VERSION.gem | \
  76. ruby -r yaml -r rbconfig -e '
  77. c = RbConfig::CONFIG
  78. path = sprintf("%s/%s/gems/%s",
  79. c["libdir"],
  80. c["RUBY_INSTALL_NAME"],
  81. c["ruby_version"])
  82. sys_gemspecs = Dir.glob(path + "/specifications/**/*.gemspec").map {|g| gs = Gem::Specification.load(g); gs.name }
  83. obj = Gem::Specification.from_yaml($stdin)
  84. obj.dependencies.each {|dep|
  85. if not(dep.type == :runtime)
  86. next
  87. end
  88. if not(sys_gemspecs.include?(dep.name))
  89. $stderr.write("WARNING: #{dep.name} gem not found\n")
  90. sleep 0.5
  91. end
  92. }'
  93. gem install \
  94. --local \
  95. --no-update-sources \
  96. --ignore-dependencies \
  97. --backtrace \
  98. --install-dir $PKG/$DESTDIR \
  99. --bindir $PKG/usr/bin \
  100. $CWD/$SRCNAM-$VERSION.gem
  101. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  102. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  103. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  104. tar -x -O --file=$CWD/$SRCNAM-$VERSION.gem data.tar.gz \
  105. | tar -xz -C $PKG/usr/doc/$PRGNAM-$VERSION --file=- \
  106. AUTHORS COPYING GPL NEWS README.rdoc
  107. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  108. mkdir -p $PKG/install
  109. cat $CWD/slack-desc > $PKG/install/slack-desc
  110. cd $PKG
  111. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE