renderdoc.SlackBuild 3.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131
  1. #!/bin/bash
  2. # Slackware build script for renderdoc
  3. # Copyright 2020 Hunter Sezen California, USA
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=renderdoc
  24. VERSION=${VERSION:-1.11}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. if [ -z "$ARCH" ]; then
  29. case "$( uname -m )" in
  30. i?86) ARCH=i586 ;;
  31. arm*) ARCH=arm ;;
  32. *) ARCH=$( uname -m ) ;;
  33. esac
  34. fi
  35. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  36. # the name of the created package would be, and then exit. This information
  37. # could be useful to other scripts.
  38. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  39. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  40. exit 0
  41. fi
  42. TMP=${TMP:-/tmp/SBo}
  43. PKG=$TMP/package-$PRGNAM
  44. OUTPUT=${OUTPUT:-/tmp}
  45. if [ "$ARCH" = "x86_64" ]; then
  46. SLKCFLAGS="-O2 -fPIC"
  47. LIBDIRSUFFIX="64"
  48. else
  49. # https://github.com/baldurk/renderdoc/issues/1991#issuecomment-670518428
  50. printf %s\\n 'Only x86_64 is supported for linux.' >&2
  51. exit 1
  52. fi
  53. set -eu
  54. rm -rf $PKG
  55. mkdir -p $TMP $PKG $OUTPUT
  56. cd $TMP
  57. rm -rf $PRGNAM-$VERSION
  58. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  59. cd $PRGNAM-$VERSION
  60. chown -R root:root .
  61. find -L . \
  62. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  63. -o -perm 511 \) -exec chmod 755 {} \; -o \
  64. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  65. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  66. if [ "${DEBUG:=0}" != 0 ]; then
  67. RELEASE=Debug
  68. SLKCFLAGS="$(printf %s "$SLKCFLAGS" | sed 's/-O2/-O0/')"
  69. else
  70. RELEASE=Release
  71. fi
  72. if [ "${QT:-yes}" = yes ] && pkg-config --exists Qt5Core python3; then
  73. GUI=ON
  74. else
  75. GUI=OFF
  76. fi
  77. grep -rl "share/doc/$PRGNAM" |
  78. xargs sed -i "s|share/doc/$PRGNAM|doc/$PRGNAM-$VERSION|"
  79. mkdir -p build
  80. cd build
  81. cmake \
  82. -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
  83. -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
  84. -DCMAKE_INSTALL_PREFIX=/usr \
  85. -DLIB_SUFFIX=${LIBDIRSUFFIX} \
  86. -DQMAKE_QT5_COMMAND=qmake-qt5 \
  87. -DLIB_SUBFOLDER=$PRGNAM \
  88. -DVULKAN_LAYER_FOLDER=/usr/share/vulkan/implicit_layer.d \
  89. -DRENDERDOC_SWIG_PACKAGE="$CWD/swig-$PRGNAM-modified-7.tar.gz" \
  90. -DENABLE_PYRENDERDOC=$GUI \
  91. -DENABLE_QRENDERDOC=$GUI \
  92. -DBUILD_VERSION_STABLE=ON \
  93. -DBUILD_VERSION_DIST_NAME=slackware \
  94. -DBUILD_VERSION_DIST_CONTACT='https://lists.slackbuilds.org/' \
  95. -DCMAKE_BUILD_TYPE=$RELEASE ..
  96. make
  97. make install DESTDIR=$PKG
  98. cd ..
  99. # renderdoc explicity depends on CMAKE_INSTALL_RPATH
  100. # -DCMAKE_SKIP_RPATH=TRUE \
  101. if [ "$DEBUG" = 0 ]; then
  102. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" |
  103. grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  104. fi
  105. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  106. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  107. mkdir -p $PKG/install
  108. cat $CWD/slack-desc > $PKG/install/slack-desc
  109. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  110. cd $PKG
  111. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE