meh.SlackBuild 3.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102
  1. #!/bin/bash
  2. # Slackware build script for meh
  3. # Copyright 2014 Leonard Schmidt <email removed>
  4. # All rights reserved.
  5. #
  6. # Permission to use, copy, modify, and distribute this software for any purpose
  7. # with or without fee is hereby granted, provided that the above copyright
  8. # notice and this permission notice appear in all copies.
  9. #
  10. # THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESSED OR IMPLIED WARRANTIES,
  11. # INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND
  12. # FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
  13. # AUTHORS AND COPYRIGHT HOLDERS AND THEIR CONTRIBUTORS BE LIABLE FOR ANY
  14. # DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
  15. # (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
  16. # LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
  17. # ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
  18. # (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
  19. # THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  20. # Now maintained by B. Watson <urchlay@slackware.uk>.
  21. # 20180628 bkw:
  22. # - Take over maintenance.
  23. # - Add man page, BUILD=2
  24. # - Script simplifications.
  25. cd $(dirname $0) ; CWD=$(pwd)
  26. PRGNAM=meh
  27. VERSION=${VERSION:-0.3}
  28. BUILD=${BUILD:-2}
  29. TAG=${TAG:-_SBo}
  30. PKGTYPE=${PKGTYPE:-tgz}
  31. if [ -z "$ARCH" ]; then
  32. case "$( uname -m )" in
  33. i?86) ARCH=i586 ;;
  34. arm*) ARCH=arm ;;
  35. *) ARCH=$( uname -m ) ;;
  36. esac
  37. fi
  38. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  39. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  40. exit 0
  41. fi
  42. TMP=${TMP:-/tmp/SBo}
  43. PKG=$TMP/package-$PRGNAM
  44. OUTPUT=${OUTPUT:-/tmp}
  45. if [ "$ARCH" = "i586" ]; then
  46. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  47. LIBDIRSUFFIX=""
  48. elif [ "$ARCH" = "i686" ]; then
  49. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  50. LIBDIRSUFFIX=""
  51. elif [ "$ARCH" = "x86_64" ]; then
  52. SLKCFLAGS="-O2 -fPIC"
  53. LIBDIRSUFFIX="64"
  54. else
  55. SLKCFLAGS="-O2"
  56. LIBDIRSUFFIX=""
  57. fi
  58. set -e
  59. rm -rf $PKG
  60. mkdir -p $TMP $PKG $OUTPUT
  61. cd $TMP
  62. rm -rf $PRGNAM-$VERSION
  63. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  64. cd $PRGNAM-$VERSION
  65. chown -R root:root .
  66. find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
  67. \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
  68. # Fixes for giflib-5.1 from https://github.com/jhawthorn/meh
  69. patch -p1 < $CWD/meh-giflib.patch
  70. CFLAGS="$SLKCFLAGS" make
  71. install -D -s -o root -g root -m 755 $PRGNAM $PKG/usr/bin/$PRGNAM
  72. # 20180628 bkw: Man page originally came from upstream's git, and I
  73. # added the key bindings section (and sent a patch upstream, hopefully
  74. # he likes it).
  75. mkdir -p $PKG/usr/man/man1
  76. gzip -9c < $CWD/$PRGNAM.1 > $PKG/usr/man/man1/$PRGNAM.1.gz
  77. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  78. cp -a AUTHORS BUGS COPYING NEWS README THANKS $PKG/usr/doc/$PRGNAM-$VERSION
  79. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  80. mkdir -p $PKG/install
  81. cat $CWD/slack-desc > $PKG/install/slack-desc
  82. cd $PKG
  83. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE