12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364 |
- #!/bin/bash
- # Slackware build script for ECI (European Color Initiative) ICC profiles
- # Copyright 2019 Klaatu | Lawrence, NZ | klaatu@member.fsf.org
- # GNU All-Permissive License
- # Copying and distribution of this file, with or without modification,
- # are permitted in any medium without royalty provided the copyright
- # notice and this notice are preserved. This file is offered as-is,
- # without any warranty.
- cd $(dirname $0) ; CWD=$(pwd)
- PRGNAM=icc_profiles_from_eci
- VERSION=${VERSION:-"2017_08_27"}
- BUILD=${BUILD:-1}
- TAG=${TAG:-_SBo}
- PKGTYPE=${PKGTYPE:-tgz}
- ARCH=noarch
- ECINAM=eciRGB_v2_profile
- CMYKNAM=ecicmyk
- DEVICELINK=ecicmyk_devicelinkprofiles_$(echo $VERSION | tr _ -)
- # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
- # the name of the created package would be, and then exit. This information
- # could be useful to other scripts.
- if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
- fi
- TMP=${TMP:-/tmp/SBo}
- PKG=$TMP/package-$PRGNAM
- OUTPUT=${OUTPUT:-/tmp}
- set -e
- rm -rf $PKG
- mkdir -p $TMP $PKG $OUTPUT
- cd $TMP
- rm -rf $PRGNAM-$VERSION $ECINAM ${CMYKNAM}.icc
- unzip $CWD/ecirgbv20.zip
- install -d $PKG/usr/share/color/icc/
- install -m644 "${ECINAM}"/*.icc \
- $PKG/usr/share/color/icc/
- unzip $CWD/$CMYKNAM.zip -d $PKG/usr/share/color/icc/
- unzip $CWD/$DEVICELINK.zip -d $PKG/usr/share/color/icc/
- rm -rf $PKG/usr/share/color/icc/__MACOSX/
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- install -m644 "${ECINAM}"/licence.rtf \
- $PKG/usr/doc/${PRGNAM}-$VERSION
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- mkdir -p $PKG/install
- cat $CWD/slack-desc > $PKG/install/slack-desc
- cd $PKG
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|