123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155 |
- #!/bin/bash
- # Slackware build script for embree
- # Copyright 2006-2014 Robby Workman, Northport, AL, USA
- # All rights reserved.
- #
- # Redistribution and use of this script, with or without modification, is
- # permitted provided that the following conditions are met:
- #
- # 1. Redistributions of this script must retain the above copyright
- # notice, this list of conditions and the following disclaimer.
- #
- # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
- # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
- # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
- # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
- # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
- # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
- # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
- # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
- # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
- # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- cd $(dirname $0) ; CWD=$(pwd)
- PRGNAM=embree
- VERSION=${VERSION:-3.12.1}
- BUILD=${BUILD:-1}
- TAG=${TAG:-_SBo}
- PKGTYPE=${PKGTYPE:-tgz}
- if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
- fi
- # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
- # the name of the created package would be, and then exit. This information
- # could be useful to other scripts.
- if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
- fi
- TMP=${TMP:-/tmp/SBo}
- PKG=$TMP/package-$PRGNAM
- OUTPUT=${OUTPUT:-/tmp}
- if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
- else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
- fi
- set -e
- rm -rf $PKG
- mkdir -p $TMP $PKG $OUTPUT
- cd $TMP
- rm -rf $PRGNAM-$VERSION
- tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
- cd $PRGNAM-$VERSION
- chown -R root:root .
- find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
- #EMBREE_API_NAMESPACE:STRING=
- #EMBREE_BACKFACE_CULLING:BOOL=OFF
- #EMBREE_COMPACT_POLYS:BOOL=OFF
- #EMBREE_CURVE_SELF_INTERSECTION_AVOIDANCE_FACTOR:STRING=2.0
- #EMBREE_FILTER_FUNCTION:BOOL=ON
- #EMBREE_GEOMETRY_CURVE:BOOL=ON
- #EMBREE_GEOMETRY_GRID:BOOL=ON
- #EMBREE_GEOMETRY_INSTANCE:BOOL=ON
- #EMBREE_GEOMETRY_POINT:BOOL=ON
- #EMBREE_GEOMETRY_QUAD:BOOL=ON
- #EMBREE_GEOMETRY_SUBDIVISION:BOOL=ON
- #EMBREE_GEOMETRY_TRIANGLE:BOOL=ON
- #EMBREE_GEOMETRY_USER:BOOL=ON
- #EMBREE_IGNORE_CMAKE_CXX_FLAGS:BOOL=ON
- #EMBREE_IGNORE_INVALID_RAYS:BOOL=OFF
- #EMBREE_INSTALL_DEPENDENCIES:BOOL=OFF
- #EMBREE_ISA_AVX:BOOL=ON
- #EMBREE_ISA_AVX2:BOOL=ON
- #EMBREE_ISA_AVX512KNL:BOOL=OFF
- #EMBREE_ISA_AVX512SKX:BOOL=ON
- #EMBREE_ISA_SSE2:BOOL=ON
- #EMBREE_ISA_SSE42:BOOL=ON
- #EMBREE_ISPC_EXECUTABLE:FILEPATH=EMBREE_ISPC_EXECUTABLE-NOTFOUND
- #EMBREE_ISPC_SUPPORT:BOOL=ON
- #EMBREE_LIBRARY_NAME:STRING=embree3
- #EMBREE_MAX_INSTANCE_LEVEL_COUNT:STRING=1
- #EMBREE_MAX_ISA:STRING=NONE
- #EMBREE_MIN_WIDTH:BOOL=OFF
- #EMBREE_RAY_MASK:BOOL=OFF
- #EMBREE_RAY_PACKETS:BOOL=ON
- #EMBREE_STACK_PROTECTOR:BOOL=OFF
- #EMBREE_STATIC_LIB:BOOL=OFF
- #EMBREE_STAT_COUNTERS:BOOL=OFF
- #EMBREE_TASKING_SYSTEM:STRING=TBB
- #EMBREE_TUTORIALS:BOOL=ON
- #EMBREE_ZIP_MODE:BOOL=OFF
- mkdir -p build
- cd build
- cmake \
- -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_MANDIR=/usr/man \
- -DCMAKE_INSTALL_DOCDIR=/usr/doc \
- -DEMBREE_ISPC_SUPPORT=OFF \
- -DEMBREE_TASKING_SYSTEM=OFF \
- -DEMBREE_TUTORIALS=OFF \
- -DCMAKE_BUILD_TYPE=Release ..
- make VERBOSE=1
- make install DESTDIR=$PKG
- cd ..
- find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- find $PKG/usr/man -type f -exec gzip -9 {} \;
- for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- cp -a \
- third-party-programs-TBB.txt third-party-programs.txt readme.pdf README.md LICENSE.txt CHANGELOG.md doc/* \
- $PKG/usr/doc/$PRGNAM-$VERSION
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- find $PKG/usr/doc -name "Makefile*" -exec rm {} \;
- find $PKG/usr/doc -type f -exec chmod 644 {} \;
- mkdir -p $PKG/install
- cat $CWD/slack-desc > $PKG/install/slack-desc
- cd $PKG
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|