embree.SlackBuild 4.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155
  1. #!/bin/bash
  2. # Slackware build script for embree
  3. # Copyright 2006-2014 Robby Workman, Northport, AL, USA
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=embree
  24. VERSION=${VERSION:-3.12.1}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. if [ -z "$ARCH" ]; then
  29. case "$( uname -m )" in
  30. i?86) ARCH=i586 ;;
  31. arm*) ARCH=arm ;;
  32. *) ARCH=$( uname -m ) ;;
  33. esac
  34. fi
  35. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  36. # the name of the created package would be, and then exit. This information
  37. # could be useful to other scripts.
  38. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  39. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  40. exit 0
  41. fi
  42. TMP=${TMP:-/tmp/SBo}
  43. PKG=$TMP/package-$PRGNAM
  44. OUTPUT=${OUTPUT:-/tmp}
  45. if [ "$ARCH" = "i586" ]; then
  46. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  47. LIBDIRSUFFIX=""
  48. elif [ "$ARCH" = "i686" ]; then
  49. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  50. LIBDIRSUFFIX=""
  51. elif [ "$ARCH" = "x86_64" ]; then
  52. SLKCFLAGS="-O2 -fPIC"
  53. LIBDIRSUFFIX="64"
  54. else
  55. SLKCFLAGS="-O2"
  56. LIBDIRSUFFIX=""
  57. fi
  58. set -e
  59. rm -rf $PKG
  60. mkdir -p $TMP $PKG $OUTPUT
  61. cd $TMP
  62. rm -rf $PRGNAM-$VERSION
  63. tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
  64. cd $PRGNAM-$VERSION
  65. chown -R root:root .
  66. find -L . \
  67. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  68. -o -perm 511 \) -exec chmod 755 {} \; -o \
  69. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  70. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  71. #EMBREE_API_NAMESPACE:STRING=
  72. #EMBREE_BACKFACE_CULLING:BOOL=OFF
  73. #EMBREE_COMPACT_POLYS:BOOL=OFF
  74. #EMBREE_CURVE_SELF_INTERSECTION_AVOIDANCE_FACTOR:STRING=2.0
  75. #EMBREE_FILTER_FUNCTION:BOOL=ON
  76. #EMBREE_GEOMETRY_CURVE:BOOL=ON
  77. #EMBREE_GEOMETRY_GRID:BOOL=ON
  78. #EMBREE_GEOMETRY_INSTANCE:BOOL=ON
  79. #EMBREE_GEOMETRY_POINT:BOOL=ON
  80. #EMBREE_GEOMETRY_QUAD:BOOL=ON
  81. #EMBREE_GEOMETRY_SUBDIVISION:BOOL=ON
  82. #EMBREE_GEOMETRY_TRIANGLE:BOOL=ON
  83. #EMBREE_GEOMETRY_USER:BOOL=ON
  84. #EMBREE_IGNORE_CMAKE_CXX_FLAGS:BOOL=ON
  85. #EMBREE_IGNORE_INVALID_RAYS:BOOL=OFF
  86. #EMBREE_INSTALL_DEPENDENCIES:BOOL=OFF
  87. #EMBREE_ISA_AVX:BOOL=ON
  88. #EMBREE_ISA_AVX2:BOOL=ON
  89. #EMBREE_ISA_AVX512KNL:BOOL=OFF
  90. #EMBREE_ISA_AVX512SKX:BOOL=ON
  91. #EMBREE_ISA_SSE2:BOOL=ON
  92. #EMBREE_ISA_SSE42:BOOL=ON
  93. #EMBREE_ISPC_EXECUTABLE:FILEPATH=EMBREE_ISPC_EXECUTABLE-NOTFOUND
  94. #EMBREE_ISPC_SUPPORT:BOOL=ON
  95. #EMBREE_LIBRARY_NAME:STRING=embree3
  96. #EMBREE_MAX_INSTANCE_LEVEL_COUNT:STRING=1
  97. #EMBREE_MAX_ISA:STRING=NONE
  98. #EMBREE_MIN_WIDTH:BOOL=OFF
  99. #EMBREE_RAY_MASK:BOOL=OFF
  100. #EMBREE_RAY_PACKETS:BOOL=ON
  101. #EMBREE_STACK_PROTECTOR:BOOL=OFF
  102. #EMBREE_STATIC_LIB:BOOL=OFF
  103. #EMBREE_STAT_COUNTERS:BOOL=OFF
  104. #EMBREE_TASKING_SYSTEM:STRING=TBB
  105. #EMBREE_TUTORIALS:BOOL=ON
  106. #EMBREE_ZIP_MODE:BOOL=OFF
  107. mkdir -p build
  108. cd build
  109. cmake \
  110. -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
  111. -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
  112. -DCMAKE_INSTALL_PREFIX=/usr \
  113. -DCMAKE_INSTALL_MANDIR=/usr/man \
  114. -DCMAKE_INSTALL_DOCDIR=/usr/doc \
  115. -DEMBREE_ISPC_SUPPORT=OFF \
  116. -DEMBREE_TASKING_SYSTEM=OFF \
  117. -DEMBREE_TUTORIALS=OFF \
  118. -DCMAKE_BUILD_TYPE=Release ..
  119. make VERBOSE=1
  120. make install DESTDIR=$PKG
  121. cd ..
  122. find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
  123. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  124. find $PKG/usr/man -type f -exec gzip -9 {} \;
  125. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  126. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  127. cp -a \
  128. third-party-programs-TBB.txt third-party-programs.txt readme.pdf README.md LICENSE.txt CHANGELOG.md doc/* \
  129. $PKG/usr/doc/$PRGNAM-$VERSION
  130. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  131. find $PKG/usr/doc -name "Makefile*" -exec rm {} \;
  132. find $PKG/usr/doc -type f -exec chmod 644 {} \;
  133. mkdir -p $PKG/install
  134. cat $CWD/slack-desc > $PKG/install/slack-desc
  135. cd $PKG
  136. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE