123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114 |
- #!/bin/bash
- # Slackware build script for gpsbabel
- # Copyright 2017-2022 Kyle Guinn <elyk03@gmail.com>
- # All rights reserved.
- #
- # Redistribution and use of this script, with or without modification, is
- # permitted provided that the following conditions are met:
- #
- # 1. Redistributions of this script must retain the above copyright
- # notice, this list of conditions and the following disclaimer.
- #
- # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
- # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
- # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
- # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
- # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
- # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
- # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
- # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
- # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
- # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- cd $(dirname $0) ; CWD=$(pwd)
- PRGNAM=gpsbabel
- VERSION=${VERSION:-1.8.0}
- SRCVER=${PRGNAM}_$(echo ${VERSION} | tr . _)
- BUILD=${BUILD:-1}
- TAG=${TAG:-_SBo}
- PKGTYPE=${PKGTYPE:-tgz}
- if [ -z "$ARCH" ]; then
- case "$(uname -m)" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$(uname -m) ;;
- esac
- fi
- if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
- fi
- TMP=${TMP:-/tmp/SBo}
- PKG=$TMP/package-$PRGNAM-$VERSION
- OUTPUT=${OUTPUT:-/tmp}
- DOCS="AUTHORS COPYING README*"
- if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
- else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
- fi
- set -e
- rm -rf $PKG
- mkdir -p $TMP $PKG $OUTPUT
- cd $TMP
- rm -rf $PRGNAM-$SRCVER
- tar xvf $CWD/$PRGNAM-$SRCVER.tar.gz
- cd $PRGNAM-$SRCVER
- chown -R root:root .
- chmod -R u+w,go-w,a+rX-st .
- # Protect your privacy: Turn off usage reporting and checks for upgrades
- # by default. These can be enabled manually via the preferences window.
- # Upgrade checking is broken (for me, at least) so this silences an error dialog.
- sed -i \
- -e '/reportStatistics_/s/true/false/' \
- -e '/startupVersionCheck_/s/true/false/' \
- -e '/ignoreVersionMismatch_/s/false/true/' \
- gui/babeldata.h
- # Resize the icon from 500x476 to 512x512. Thanks to Arch.
- convert gui/images/appicon.png +set date:create +set date:modify -background none -gravity center -extent 512x512 gui/images/appicon.png
- qmake-qt5 \
- WITH_LIBUSB=pkgconfig \
- WITH_ZLIB=pkgconfig \
- QMAKE_CFLAGS_RELEASE="$SLKCFLAGS" \
- QMAKE_CXXFLAGS_RELEASE="$SLKCFLAGS" \
- make
- make gui
- install -D -m0755 -s gpsbabel $PKG/usr/bin/gpsbabel
- install -D -m0755 -s gui/objects/gpsbabelfe $PKG/usr/bin/gpsbabelfe
- install -D -m0644 gui/gpsbabel.desktop $PKG/usr/share/applications/gpsbabel.desktop
- install -D -m0644 gui/images/appicon.png $PKG/usr/share/icons/hicolor/512x512/apps/gpsbabel.png
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- mkdir -p $PKG/install
- cat $CWD/slack-desc > $PKG/install/slack-desc
- cat $CWD/doinst.sh > $PKG/install/doinst.sh
- cd $PKG
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|