skrooge.SlackBuild 3.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114
  1. #!/bin/bash
  2. # Copyright 2012,2016 Vincent Batts, Raleigh, NC, USA
  3. # Copyright 2009 Vincent Batts, http://hashbangbash.com/
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=skrooge
  24. VERSION=${VERSION:-2.27.0}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. if [ -z "$ARCH" ]; then
  29. case "$( uname -m )" in
  30. i?86) export ARCH=i586 ;;
  31. arm*) export ARCH=arm ;;
  32. *) export ARCH=$( uname -m ) ;;
  33. esac
  34. fi
  35. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  36. # the name of the created package would be, and then exit. This information
  37. # could be useful to other scripts.
  38. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  39. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  40. exit 0
  41. fi
  42. TMP=${TMP:-/tmp/SBo}
  43. PKG=$TMP/package-$PRGNAM
  44. OUTPUT=${OUTPUT:-/tmp}
  45. if [ "$ARCH" = "i586" ]; then
  46. export SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  47. export LIBDIRSUFFIX=""
  48. elif [ "$ARCH" = "s390" ]; then
  49. export SLKCFLAGS="-O2"
  50. export LIBDIRSUFFIX=""
  51. elif [ "$ARCH" = "x86_64" ]; then
  52. export SLKCFLAGS="-O2 -fPIC"
  53. export LIBDIRSUFFIX="64"
  54. elif [ "$ARCH" = "arm" ]; then
  55. export SLKCFLAGS="-O2 -march=armv4 -mtune=xscale"
  56. export LIBDIRSUFFIX=""
  57. elif [ "$ARCH" = "armel" ]; then
  58. export SLKCFLAGS="-O2 -march=armv4t"
  59. export LIBDIRSUFFIX=""
  60. fi
  61. # Additional cmake flags that are spanned across the KDE modules
  62. export KDE_OPT_ARGS=" -DSITE=\"slackbuilds.org\" "
  63. set -e
  64. rm -rf $PKG
  65. mkdir -p $TMP $PKG/usr $OUTPUT
  66. cd $TMP
  67. tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
  68. cd $PRGNAM-$VERSION
  69. chown -R root:root .
  70. find -L . \
  71. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
  72. -exec chmod 755 {} \; -o \
  73. \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
  74. -exec chmod 644 {} \;
  75. mkdir -p build
  76. cd build
  77. cmake \
  78. $KDE_OPT_ARGS \
  79. -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
  80. -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
  81. -DCMAKE_BUILD_TYPE=Release \
  82. -DCMAKE_INSTALL_PREFIX=/usr \
  83. -DMAN_INSTALL_DIR=/usr/man \
  84. -DSYSCONF_INSTALL_DIR=/etc/kde \
  85. -DLIB_SUFFIX=${LIBDIRSUFFIX} \
  86. ..
  87. make
  88. make install DESTDIR=$PKG
  89. cd -
  90. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  91. cp -a COPYING* $PKG/usr/doc/$PRGNAM-$VERSION
  92. find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
  93. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  94. mkdir -p $PKG/install
  95. cat $CWD/slack-desc > $PKG/install/slack-desc
  96. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  97. cd $PKG
  98. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE