clap.SlackBuild 2.7 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788
  1. #!/bin/bash
  2. # Slackware build script for clap
  3. # Copyright Martin Bångens Sweden
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=clap
  24. VERSION=${VERSION:-1.1.7}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. ARCH=noarch
  29. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  30. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  31. exit 0
  32. fi
  33. TMP=${TMP:-/tmp/SBo}
  34. PKG=$TMP/package-$PRGNAM
  35. OUTPUT=${OUTPUT:-/tmp}
  36. set -e
  37. rm -rf $PKG
  38. mkdir -p $TMP $PKG $OUTPUT
  39. cd $TMP
  40. rm -rf $PRGNAM-$VERSION
  41. tar xf $CWD/$PRGNAM-$VERSION.tar.gz
  42. cd $PRGNAM-$VERSION
  43. chown -R root:root .
  44. find -L . \
  45. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  46. -o -perm 511 \) -exec chmod 755 {} \; -o \
  47. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  48. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  49. mkdir -p $PKG/usr/share/pkgconfig
  50. cp $CWD/clap.pc $PKG/usr/share/pkgconfig/
  51. sed -i "s/VERSION/$VERSION/g" $PKG/usr/share/pkgconfig/clap.pc
  52. mkdir -p $PKG/usr/include
  53. cp -a include/clap $PKG/usr/include/
  54. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  55. cp -a \
  56. ChangeLog.md \
  57. Contributors.md \
  58. LICENSE \
  59. README.md \
  60. artwork \
  61. $PKG/usr/doc/$PRGNAM-$VERSION
  62. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  63. chmod 755 $PKG/usr/include/clap
  64. find $PKG/usr/include/clap -type d -exec chmod 755 {} +
  65. find $PKG/usr/include/clap -type f -exec chmod 644 {} +
  66. chmod 755 $PKG/usr/doc/$PRGNAM-$VERSION
  67. find $PKG/usr/doc/$PRGNAM-$VERSION -type d -exec chmod 755 {} +
  68. find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 644 {} +
  69. mkdir -p $PKG/install
  70. cat $CWD/slack-desc > $PKG/install/slack-desc
  71. cd $PKG
  72. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE