ardour.SlackBuild 4.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142
  1. #!/bin/bash
  2. # Slackware build script for ardour
  3. # Copyright 2008-2016 Heinz Wiesinger, Amsterdam, The Netherlands
  4. # Copyright 2018-2021 Matteo Bernardini, Pisa, Italy
  5. # All rights reserved.
  6. #
  7. # Redistribution and use of this script, with or without modification, is
  8. # permitted provided that the following conditions are met:
  9. #
  10. # 1. Redistributions of this script must retain the above copyright
  11. # notice, this list of conditions and the following disclaimer.
  12. #
  13. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
  14. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  15. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  16. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  17. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  18. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  19. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  20. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  21. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  22. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  23. cd $(dirname $0) ; CWD=$(pwd)
  24. PRGNAM=ardour
  25. VERSION=${VERSION:-6.9}
  26. BUILD=${BUILD:-1}
  27. TAG=${TAG:-_SBo}
  28. PKGTYPE=${PKGTYPE:-tgz}
  29. if [ -z "$ARCH" ]; then
  30. case "$( uname -m )" in
  31. i?86) ARCH=i586 ;;
  32. arm*) ARCH=arm ;;
  33. *) ARCH=$( uname -m ) ;;
  34. esac
  35. fi
  36. if [ "$ARCH" = "i586" ]; then
  37. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  38. LIBDIRSUFFIX=""
  39. TARGET="i386"
  40. elif [ "$ARCH" = "i686" ]; then
  41. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  42. LIBDIRSUFFIX=""
  43. TARGET="i686"
  44. elif [ "$ARCH" = "x86_64" ]; then
  45. SLKCFLAGS="-O2 -fPIC"
  46. LIBDIRSUFFIX="64"
  47. TARGET="x86_64"
  48. else
  49. SLKCFLAGS="-O2"
  50. LIBDIRSUFFIX=""
  51. TARGET="$ARCH"
  52. fi
  53. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  54. # the name of the created package would be, and then exit. This information
  55. # could be useful to other scripts.
  56. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  57. echo "$PRGNAM-$VERSION-$TARGET-$BUILD$TAG.$PKGTYPE"
  58. exit 0
  59. fi
  60. TMP=${TMP:-/tmp/SBo}
  61. PKG=$TMP/package-$PRGNAM
  62. OUTPUT=${OUTPUT:-/tmp}
  63. set -e
  64. rm -rf $PKG
  65. mkdir -p $TMP $PKG $OUTPUT
  66. cd $TMP
  67. rm -rf Ardour-$VERSION
  68. tar xvf $CWD/Ardour-$VERSION.tar.?z*
  69. cd Ardour-$VERSION
  70. chown -R root:root .
  71. find -L . \
  72. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  73. -o -perm 511 \) -exec chmod 755 {} \; -o \
  74. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  75. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  76. patch -p1 < $CWD/vendor_qm-dsp.patch
  77. CFLAGS="$SLKCFLAGS" \
  78. CXXFLAGS="$SLKCFLAGS -std=c++11 -fpermissive" \
  79. ./waf configure \
  80. --prefix=/usr \
  81. --libdir=/usr/lib${LIBDIRSUFFIX} \
  82. --configdir=/etc \
  83. --mandir=/usr/man \
  84. --docdir=/usr/doc/$PRGNAM-$VERSION \
  85. --with-backends="dummy,alsa,jack,pulseaudio" \
  86. --libjack=weak \
  87. --optimize \
  88. --freedesktop \
  89. --no-phone-home \
  90. --nls \
  91. --ptformat \
  92. --lxvst \
  93. --cxx11
  94. ./waf build
  95. ./waf install --destdir=$PKG
  96. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  97. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  98. mkdir -p $PKG/usr/share/{appdata,applications,icons}
  99. cp build/gtk2_ardour/ardour6.appdata.xml $PKG/usr/share/appdata/
  100. cp build/gtk2_ardour/ardour6.desktop $PKG/usr/share/applications/
  101. for isize in 16 22 32 48 ; do
  102. mkdir -p $PKG/usr/share/icons/hicolor/${isize}x${isize}/apps
  103. cp gtk2_ardour/icons/application-x-ardour_${isize}px.png \
  104. $PKG/usr/share/icons/hicolor/${isize}x${isize}/apps/ardour6.png
  105. done
  106. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  107. cp -a COPYING PACKAGER_README README TRANSLATORS \
  108. $PKG/usr/doc/$PRGNAM-$VERSION
  109. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  110. mkdir -p $PKG/install
  111. cat $CWD/slack-desc > $PKG/install/slack-desc
  112. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  113. # Let's not clobber config files
  114. cd $PKG/etc/ardour6
  115. for i in $(find . -type f) ; do
  116. mv $i $i.new
  117. echo "config etc/ardour6/$i.new" >> $PKG/install/doinst.sh
  118. done
  119. cd -
  120. cd $PKG
  121. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$TARGET-$BUILD$TAG.$PKGTYPE