1234567891011121314151617181920212223242526272829303132333435363738394041424344 |
- # Do not modify this file! It was generated by ‘nixos-generate-config’
- # and may be overwritten by future invocations. Please make changes
- # to /etc/nixos/configuration.nix instead.
- { config, lib, pkgs, modulesPath, ... }:
- {
- imports = [ (modulesPath + "/installer/scan/not-detected.nix") ];
- boot.initrd.availableKernelModules =
- [ "xhci_pci" "ehci_pci" "ahci" "sd_mod" ];
- boot.initrd.kernelModules = [ "dm-snapshot" ];
- boot.kernelModules = [ "kvm-intel" ];
- boot.extraModulePackages = [ ];
- fileSystems."/" = {
- device = "/dev/disk/by-label/nixos-root";
- fsType = "ext4";
- };
- fileSystems."/boot" = {
- device = "/dev/disk/by-uuid/4963-B2FC";
- fsType = "vfat";
- };
- fileSystems."/home" = {
- device = "/dev/disk/by-label/nixos-home";
- fsType = "ext4";
- };
- swapDevices = [{ device = "/dev/disk/by-label/nixos-swap"; }];
- # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
- # (the default) this is the recommended approach. When using systemd-networkd it's
- # still possible to use this option, but it's recommended to use it in conjunction
- # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
- networking.useDHCP = lib.mkDefault true;
- # networking.interfaces.enp0s25.useDHCP = lib.mkDefault true;
- # networking.interfaces.wlp3s0.useDHCP = lib.mkDefault true;
- powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
- hardware.cpu.intel.updateMicrocode =
- lib.mkDefault config.hardware.enableRedistributableFirmware;
- }
|