hardware-configuration.nix 1.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Do not modify this file! It was generated by ‘nixos-generate-config’
  2. # and may be overwritten by future invocations. Please make changes
  3. # to /etc/nixos/configuration.nix instead.
  4. { config, lib, pkgs, modulesPath, ... }:
  5. {
  6. imports = [ (modulesPath + "/installer/scan/not-detected.nix") ];
  7. boot.initrd.availableKernelModules =
  8. [ "xhci_pci" "ehci_pci" "ahci" "sd_mod" ];
  9. boot.initrd.kernelModules = [ "dm-snapshot" ];
  10. boot.kernelModules = [ "kvm-intel" ];
  11. boot.extraModulePackages = [ ];
  12. fileSystems."/" = {
  13. device = "/dev/disk/by-label/nixos-root";
  14. fsType = "ext4";
  15. };
  16. fileSystems."/boot" = {
  17. device = "/dev/disk/by-uuid/4963-B2FC";
  18. fsType = "vfat";
  19. };
  20. fileSystems."/home" = {
  21. device = "/dev/disk/by-label/nixos-home";
  22. fsType = "ext4";
  23. };
  24. swapDevices = [{ device = "/dev/disk/by-label/nixos-swap"; }];
  25. # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
  26. # (the default) this is the recommended approach. When using systemd-networkd it's
  27. # still possible to use this option, but it's recommended to use it in conjunction
  28. # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
  29. networking.useDHCP = lib.mkDefault true;
  30. # networking.interfaces.enp0s25.useDHCP = lib.mkDefault true;
  31. # networking.interfaces.wlp3s0.useDHCP = lib.mkDefault true;
  32. powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
  33. hardware.cpu.intel.updateMicrocode =
  34. lib.mkDefault config.hardware.enableRedistributableFirmware;
  35. }