flake.nix 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. {
  2. description = "Home Manager + NixOS configuration of Abdullah Khabir";
  3. inputs = {
  4. nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
  5. hardware.url = "github:nixos/nixos-hardware";
  6. home-manager = {
  7. url = "github:nix-community/home-manager";
  8. inputs.nixpkgs.follows = "nixpkgs";
  9. };
  10. };
  11. outputs = { self, nixpkgs, home-manager, ... }:
  12. let
  13. system = "x86_64-linux";
  14. pkgs = nixpkgs.legacyPackages.${system};
  15. in {
  16. homeConfigurations.ak = home-manager.lib.homeManagerConfiguration {
  17. inherit pkgs;
  18. modules = [
  19. ./dots/home.nix
  20. {
  21. home = {
  22. username = "ak";
  23. homeDirectory = "/home/ak";
  24. stateVersion = "22.11";
  25. };
  26. }
  27. ];
  28. #extraSpecialArgs.repos = { inherit stacktile river; };
  29. };
  30. nixosConfigurations.x1c = nixpkgs.lib.nixosSystem {
  31. #inherit pkgs;
  32. system = "x86_64-linux";
  33. modules =
  34. [ ./nixos/configuration.nix ./nixos/hardware-configuration.nix ];
  35. };
  36. };
  37. }