termite.nix 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Termite
  2. { pkgs, ... }:
  3. {
  4. programs = {
  5. termite = {
  6. enable = true;
  7. allowBold = true;
  8. audibleBell = false;
  9. backgroundColor = "#000000";
  10. clickableUrl = true;
  11. cursorBlink = "off";
  12. cursorShape = "underline";
  13. cursorColor = "#d0d0d0";
  14. cursorForegroundColor = "#00ff00";
  15. dynamicTitle = true;
  16. filterUnmatchedUrls = true;
  17. fullscreen = true;
  18. geometry = "70x20";
  19. font = "codingfonttobi 19";
  20. highlightColor = "#2f2f2f";
  21. hintsActiveBackgroundColor = "#3f3f3f";
  22. hintsActiveForegroundColor = "#e68080";
  23. hintsBackgroundColor = "#dcdccc";
  24. hintsBorderColor = "#333232";
  25. hintsBorderWidth = "0.5";
  26. hintsExtra = ''
  27. padding = 2
  28. quick_url = true
  29. roundness = 2.0
  30. '';
  31. hintsFont = "Terminus 17";
  32. hintsForegroundColor = "#b1d0e8";
  33. iconName = "terminal";
  34. modifyOtherKeys = false;
  35. mouseAutohide = true;
  36. scrollOnKeystroke = true;
  37. scrollOnOutput = false;
  38. scrollbackLines = -1;
  39. scrollbar = "off";
  40. searchWrap = true;
  41. sizeHints = true;
  42. urgentOnBell = true;
  43. };
  44. };
  45. }