wayland-overlay.nix 1.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556
  1. { lib, pkgs, repos, ... }:
  2. {
  3. nixpkgs.overlays = [
  4. (self: super: {
  5. river = super.river.overrideAttrs (old: {
  6. version = repos.river.rev;
  7. src = repos.river.outPath;
  8. });
  9. stacktile = pkgs.stdenv.mkDerivation rec {
  10. pname = "stacktile";
  11. version = repos.stacktile.rev;
  12. src = repos.stacktile.outPath;
  13. installFlags = [ "PREFIX=${placeholder "out"}" ];
  14. buildInputs = with pkgs; [ wayland wayland-protocols ];
  15. meta = with lib; {
  16. description = "A layout generator for the river wayland compositor";
  17. homepage = "https://git.sr.ht/~leon_plickat/stacktile";
  18. license = licenses.gpl3Only;
  19. platforms = platforms.linux;
  20. };
  21. };
  22. waylock = pkgs.stdenv.mkDerivation rec {
  23. pname = "waylock";
  24. version = repos.waylock.rev;
  25. src = repos.waylock.outPath;
  26. installFlags = [ "PREFIX=${placeholder "out"}" ];
  27. nativeBuildInputs = with pkgs; [ pkg-config zig wayland scdoc];
  28. buildInputs = with pkgs; [ zig wayland-protocols pam libxkbcommon ];
  29. dontConfigure = true;
  30. preBuild = ''
  31. export HOME="$(mktemp -d)"
  32. '';
  33. installPhase = ''
  34. zig build -Drelease-safe -Dcpu=baseline install --prefix $out
  35. '';
  36. meta = with lib; {
  37. description = "A screen locker for wayland";
  38. homepage = "https://github.com/ifreund/waylock";
  39. license = licenses.isc;
  40. platforms = platforms.linux;
  41. };
  42. };
  43. })
  44. ];
  45. }