hyprland.nix 728 B

1234567891011121314151617181920212223242526272829
  1. { pkgs, config, lib, inputs, ... }:
  2. {
  3. # Symlink hyprland.conf
  4. xdg.configFile."hypr/hyprland.conf".source =
  5. config.lib.file.mkOutOfStoreSymlink ./hypr/hyprland.conf;
  6. # Create a target session for hyprland
  7. systemd.user.targets.hyprland-session = {
  8. Unit = {
  9. Description = "Hyprland compositor Session";
  10. Documentation = [ "man:systemd.special(7)" ];
  11. BindsTo = [ "graphical-session.target" ];
  12. Wants = [ "graphical-session-pre.target" ];
  13. After = [ "graphical-session-pre.target" ];
  14. };
  15. };
  16. # Home-Manager system tray
  17. systemd.user.targets.tray = {
  18. Unit = {
  19. Description = "Home Manager System Tray";
  20. Requires = [ "graphical-session-pre.target" ];
  21. };
  22. };
  23. }