home.nix 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061
  1. { config, pkgs, ... }:
  2. {
  3. home.username = "ak";
  4. home.homeDirectory = "/home/ak";
  5. home.stateVersion = "22.11";
  6. # Just keep home.nix short and simple. and give every program a single dedicated file.
  7. # then import them here.
  8. imports = [
  9. ./alacritty.nix
  10. #./foot.nix
  11. #./termite.nix
  12. ./feh.nix
  13. ./fonts.nix
  14. ./mako.nix
  15. ./mail.nix
  16. ./gpg-agent.nix
  17. ./go.nix
  18. ./git.nix
  19. #./hyprland.nix
  20. #./kitty.nix
  21. ./keychain.nix
  22. ./mpd.nix
  23. ./ncmpcpp.nix
  24. ./misc.nix
  25. ./mpv.nix
  26. ./packages.nix
  27. #./bspwm.nix
  28. #./sxhkd.nix
  29. #./bspwm_without_hm.nix
  30. #./picom.nix
  31. #./redshift.nix
  32. #./river.nix
  33. ./scripts.nix
  34. ./ssh.nix
  35. ./sway.nix
  36. ./tmux.nix
  37. ./variables.nix
  38. ./vim.nix
  39. ./waybar.nix
  40. ./wofi.nix
  41. #./wlsunset.nix
  42. ./urxvt.nix
  43. ./zathura.nix
  44. ./zsh.nix
  45. ];
  46. systemd.user.startServices = "suggest";
  47. # Allow unFree packages in userspace with flakes + Home-Manager
  48. nixpkgs.config.allowUnfreePredicate = (_: true);
  49. # home.stateVersion = "22.11";
  50. # Let Home Manager install and manage itself.
  51. programs.home-manager.enable = true;
  52. }