wigust-xorg.scm 3.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
  3. ;;;
  4. ;;; This file is part of GNU Guix.
  5. ;;;
  6. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  7. ;;; under the terms of the GNU General Public License as published by
  8. ;;; the Free Software Foundation; either version 3 of the License, or (at
  9. ;;; your option) any later version.
  10. ;;;
  11. ;;; GNU Guix is distributed in the hope that it will be useful, but
  12. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  13. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  14. ;;; GNU General Public License for more details.
  15. ;;;
  16. ;;; You should have received a copy of the GNU General Public License
  17. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  18. (define-module (gnu packages wigust-xorg)
  19. #:use-module ((guix licenses) #:prefix license:)
  20. #:use-module (guix packages)
  21. #:use-module (guix download)
  22. #:use-module (guix git-download)
  23. #:use-module (guix build-system gnu)
  24. #:use-module (guix build-system perl)
  25. #:use-module (guix build-system python)
  26. #:use-module (guix utils)
  27. #:use-module (gnu packages)
  28. #:use-module (gnu packages anthy)
  29. #:use-module (gnu packages autotools)
  30. #:use-module (gnu packages bison)
  31. #:use-module (gnu packages check)
  32. #:use-module (gnu packages compression)
  33. #:use-module (gnu packages emacs)
  34. #:use-module (gnu packages flex)
  35. #:use-module (gnu packages fontutils)
  36. #:use-module (gnu packages freedesktop)
  37. #:use-module (gnu packages gettext)
  38. #:use-module (gnu packages gl)
  39. #:use-module (gnu packages glib)
  40. #:use-module (gnu packages gnupg)
  41. #:use-module (gnu packages gperf)
  42. #:use-module (gnu packages gtk)
  43. #:use-module (gnu packages image)
  44. #:use-module (gnu packages libbsd)
  45. #:use-module (gnu packages libedit)
  46. #:use-module (gnu packages linux)
  47. #:use-module (gnu packages llvm)
  48. #:use-module (gnu packages m4)
  49. #:use-module (gnu packages ncurses)
  50. #:use-module (gnu packages pciutils)
  51. #:use-module (gnu packages perl)
  52. #:use-module (gnu packages perl-check)
  53. #:use-module (gnu packages pkg-config)
  54. #:use-module (gnu packages python)
  55. #:use-module (gnu packages python-crypto)
  56. #:use-module (gnu packages qt)
  57. #:use-module (gnu packages spice)
  58. #:use-module (gnu packages video)
  59. #:use-module (gnu packages xiph)
  60. #:use-module (gnu packages xml)
  61. #:use-module (gnu packages xdisorg)
  62. #:use-module (gnu packages xorg))
  63. (define-public libxss
  64. (package
  65. (name "libxss")
  66. (version "1.2.2")
  67. (source
  68. (origin
  69. (method url-fetch)
  70. (uri (string-append
  71. "mirror://xorg/individual/lib/libXss-"
  72. version
  73. ".tar.bz2"))
  74. (sha256
  75. (base32
  76. "0j89cnb06g8x79wmmnwzykgkkfdhin9j7hjpvsxwlr3fz1wmjvf0"))))
  77. (build-system gnu-build-system)
  78. (inputs
  79. `(("libx11" ,libx11)
  80. ("libext" ,libxext)))
  81. (native-inputs
  82. `(("pkg-config" ,pkg-config)
  83. ("scrnsaverproto" ,scrnsaverproto)))
  84. (home-page "https://www.x.org/wiki/")
  85. (synopsis "X11 Screen Saver extension library")
  86. (description "libXss provides an X Window System client interface to the
  87. MIT-SCREEN-SAVER extension to the X11 protocol.")
  88. (license license:x11)))