wigust-ruby.scm 9.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2017, 2018 Oleg Pykhalov <go.wigust@gmail.com>
  3. ;;;
  4. ;;; This file is part of GNU Guix.
  5. ;;;
  6. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  7. ;;; under the terms of the GNU General Public License as published by
  8. ;;; the Free Software Foundation; either version 3 of the License, or (at
  9. ;;; your option) any later version.
  10. ;;;
  11. ;;; GNU Guix is distributed in the hope that it will be useful, but
  12. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  13. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  14. ;;; GNU General Public License for more details.
  15. ;;;
  16. ;;; You should have received a copy of the GNU General Public License
  17. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  18. (define-module (gnu packages wigust-ruby)
  19. #:use-module ((guix licenses) #:prefix license:)
  20. #:use-module (gnu packages)
  21. #:use-module (gnu packages base)
  22. #:use-module (gnu packages compression)
  23. #:use-module (gnu packages databases)
  24. #:use-module (gnu packages readline)
  25. #:use-module (gnu packages autotools)
  26. #:use-module (gnu packages java)
  27. #:use-module (gnu packages libffi)
  28. #:use-module (gnu packages python)
  29. #:use-module (gnu packages ragel)
  30. #:use-module (gnu packages ruby)
  31. #:use-module (gnu packages tls)
  32. #:use-module (gnu packages version-control)
  33. #:use-module (guix packages)
  34. #:use-module (guix download)
  35. #:use-module (guix git-download)
  36. #:use-module (guix utils)
  37. #:use-module (guix build-system gnu)
  38. #:use-module (gnu packages xml)
  39. #:use-module (gnu packages web)
  40. #:use-module (guix build-system ruby))
  41. (define-public ruby-guard-livereload
  42. (package
  43. (name "ruby-guard-livereload")
  44. (version "2.5.2")
  45. (source
  46. (origin
  47. (method url-fetch)
  48. (uri (rubygems-uri "guard-livereload" version))
  49. (sha256
  50. (base32
  51. "0yd74gdbbv2yz2caqwpsavzw8d5fd5y446wp8rdjw8wan0yd6k8j"))))
  52. (build-system ruby-build-system)
  53. (propagated-inputs
  54. `(("ruby-em-websocket" ,ruby-em-websocket)
  55. ("ruby-guard" ,ruby-guard)
  56. ("ruby-guard-compat" ,ruby-guard-compat)
  57. ("ruby-multi-json" ,ruby-multi-json)))
  58. (arguments
  59. '(#:tests? #f)) ; no required file
  60. (synopsis "Automatically reloads your browser when files are modified.")
  61. (description "LiveReload automatically reloads your browser when 'view'
  62. files are modified.")
  63. (home-page "https://rubygems.org/gems/guard-livereload")
  64. (license license:expat)))
  65. (define-public ruby-http-parser-rb
  66. (package
  67. (name "ruby-http-parser.rb")
  68. (version "0.6.0")
  69. (source
  70. (origin
  71. (method url-fetch)
  72. (uri (rubygems-uri "http_parser.rb" version))
  73. (sha256
  74. (base32
  75. "15nidriy0v5yqfjsgsra51wmknxci2n2grliz78sf9pga3n0l7gi"))))
  76. (build-system ruby-build-system)
  77. (arguments
  78. '(#:tests? #f)) ; no required file
  79. (synopsis "Ruby bindings")
  80. (description "Ruby bindings.")
  81. (home-page "http://github.com/tmm1/http_parser.rb")
  82. (license license:expat)))
  83. (define-public ruby-em-websocket
  84. (package
  85. (name "ruby-em-websocket")
  86. (version "0.5.1")
  87. (source
  88. (origin
  89. (method url-fetch)
  90. (uri (rubygems-uri "em-websocket" version))
  91. (sha256
  92. (base32
  93. "1bsw8vjz0z267j40nhbmrvfz7dvacq4p0pagvyp17jif6mj6v7n3"))))
  94. (build-system ruby-build-system)
  95. (propagated-inputs
  96. `(("ruby-eventmachine" ,ruby-eventmachine)
  97. ("ruby-http-parser-rb" ,ruby-http-parser-rb)))
  98. (arguments
  99. '(#:tests? #f)) ; no required file
  100. (synopsis "EventMachine based WebSocket server")
  101. (description "EventMachine based WebSocket server")
  102. (home-page "http://github.com/igrigorik/em-websocket")
  103. (license #f)))
  104. (define-public ruby-gitlab
  105. (package
  106. (name "ruby-gitlab")
  107. (version "4.2.0")
  108. (source
  109. (origin
  110. (method url-fetch)
  111. (uri (rubygems-uri "gitlab" version))
  112. (sha256
  113. (base32
  114. "0wzazdmzhw72r1kkj8ckb1l9ryas582r5d7c6qb609kkfs31rg6m"))))
  115. (build-system ruby-build-system)
  116. (propagated-inputs
  117. `(("ruby-httparty" ,ruby-httparty)
  118. ("ruby-terminal-table" ,ruby-terminal-table)))
  119. (arguments
  120. `(#:tests? #f)) ; depends on non-existing file
  121. (synopsis "Ruby client and CLI for GitLab API")
  122. (description "Ruby client and CLI for GitLab API.")
  123. (home-page "https://github.com/narkoz/gitlab")
  124. (license license:bsd-3)))
  125. (define-public ruby-guard-compat
  126. (package
  127. (name "ruby-guard-compat")
  128. (version "1.2.1")
  129. (source
  130. (origin
  131. (method url-fetch)
  132. (uri (rubygems-uri "guard-compat" version))
  133. (sha256
  134. (base32
  135. "1zj6sr1k8w59mmi27rsii0v8xyy2rnsi09nqvwpgj1q10yq1mlis"))))
  136. (arguments
  137. '(#:tests? #f)) ; no required file
  138. (build-system ruby-build-system)
  139. (synopsis "Helps creating valid Guard plugins and testing them")
  140. (description "Helps creating valid Guard plugins and testing them.")
  141. (home-page "")
  142. (license license:expat)))
  143. (define-public ruby-httparty
  144. (package
  145. (name "ruby-httparty")
  146. (version "0.15.6")
  147. (source
  148. (origin
  149. (method url-fetch)
  150. (uri (rubygems-uri "httparty" version))
  151. (sha256
  152. (base32
  153. "0akybx7jkzhhf7f9na12jssfcllma905c8nl93ia89akbbicvq7v"))))
  154. (build-system ruby-build-system)
  155. (propagated-inputs
  156. `(("ruby-multi-xml" ,ruby-multi-xml)))
  157. (arguments
  158. `(#:tests? #f)) ; depends on non-existing file
  159. (synopsis "Makes http fun")
  160. (description "Makes http fun! Also, makes consuming restful web services
  161. dead easy.")
  162. (home-page "http://jnunemaker.github.com/httparty")
  163. (license license:expat)))
  164. (define-public ruby-multi-json
  165. (package
  166. (name "ruby-multi-json")
  167. (version "1.12.2")
  168. (source
  169. (origin
  170. (method url-fetch)
  171. (uri (rubygems-uri "multi_json" version))
  172. (sha256
  173. (base32
  174. "1raim9ddjh672m32psaa9niw67ywzjbxbdb8iijx3wv9k5b0pk2x"))))
  175. (build-system ruby-build-system)
  176. (arguments
  177. '(#:tests? #f)) ; no tests
  178. (synopsis "A common interface to multiple JSON libraries")
  179. (description "This package provides a common interface to multiple JSON
  180. libraries, including Oj, Yajl, the JSON gem (with C-extensions), the pure-Ruby
  181. JSON gem, NSJSONSerialization, gson.rb, JrJackson, and OkJson.")
  182. (home-page "http://github.com/intridea/multi_json")
  183. (license license:expat)))
  184. (define-public ruby-multi-xml
  185. (package
  186. (name "ruby-multi-xml")
  187. (version "0.6.0")
  188. (source
  189. (origin
  190. (method url-fetch)
  191. (uri (rubygems-uri "multi_xml" version))
  192. (sha256
  193. (base32
  194. "0lmd4f401mvravi1i1yq7b2qjjli0yq7dfc4p1nj5nwajp7r6hyj"))))
  195. (build-system ruby-build-system)
  196. (arguments
  197. `(#:tests? #f)) ; no tests
  198. (synopsis "Provides swappable XML backends utilizing LibXML")
  199. (description "Provides swappable XML backends utilizing LibXML, Nokogiri,
  200. Ox, or REXML.")
  201. (home-page "https://github.com/sferik/multi_xml")
  202. (license license:expat)))
  203. (define-public ruby-terminal-table
  204. (package
  205. (name "ruby-terminal-table")
  206. (version "1.8.0")
  207. (source
  208. (origin
  209. (method url-fetch)
  210. (uri (rubygems-uri "terminal-table" version))
  211. (sha256
  212. (base32
  213. "1512cngw35hsmhvw4c05rscihc59mnj09m249sm9p3pik831ydqk"))))
  214. (build-system ruby-build-system)
  215. (propagated-inputs
  216. `(("ruby-unicode-display-width" ,ruby-unicode-display-width)))
  217. (arguments
  218. `(#:tests? #f)) ; no tests
  219. (synopsis "Simple, feature rich ascii table generation library")
  220. (description "Simple, feature rich ascii table generation library.")
  221. (home-page "https://github.com/tj/terminal-table")
  222. (license license:expat)))
  223. (define-public ruby-unicode-display-width
  224. (package
  225. (name "ruby-unicode-display-width")
  226. (version "1.3.0")
  227. (source
  228. (origin
  229. (method url-fetch)
  230. (uri (rubygems-uri "unicode-display_width" version))
  231. (sha256
  232. (base32
  233. "12pi0gwqdnbx1lv5136v3vyr0img9wr0kxcn4wn54ipq4y41zxq8"))))
  234. (build-system ruby-build-system)
  235. (propagated-inputs
  236. `(("ruby-unicode-emoji" ,ruby-unicode-emoji)))
  237. (arguments
  238. `(#:tests? #f)) ; no tests
  239. (synopsis "Determines the monospace display width")
  240. (description "Determines the monospace display width of a string using
  241. EastAsianWidth.txt, Unicode general category, and other data.")
  242. (home-page "http://github.com/janlelis/unicode-display_width")
  243. (license license:expat)))
  244. (define-public ruby-unicode-emoji
  245. (package
  246. (name "ruby-unicode-emoji")
  247. (version "0.9.2")
  248. (source
  249. (origin
  250. (method url-fetch)
  251. (uri (rubygems-uri "unicode-emoji" version))
  252. (sha256
  253. (base32
  254. "1hrsvkdpsi534fqlk2wxvdvgykk89sajhsx7jskjncpqf8cxfcgr"))))
  255. (build-system ruby-build-system)
  256. (arguments
  257. `(#:tests? #f)) ; no tests
  258. (synopsis "Retrieve emoji data about Unicode codepoints")
  259. (description "Retrieve emoji data about Unicode codepoints. Also contains
  260. a regex to match emoji.")
  261. (home-page "https://github.com/janlelis/unicode-emoji")
  262. (license license:expat)))