rules 904 B

1234567891011121314151617181920212223242526272829303132333435
  1. #!/usr/bin/make -f
  2. # See debhelper(7) (uncomment to enable)
  3. # output every command that modifies files on the build system.
  4. #DH_VERBOSE = 1
  5. # see EXAMPLES in dpkg-buildflags(1) and read /usr/share/dpkg/*
  6. DPKG_EXPORT_BUILDFLAGS = 1
  7. include /usr/share/dpkg/default.mk
  8. # see FEATURE AREAS in dpkg-buildflags(1)
  9. #export DEB_BUILD_MAINT_OPTIONS = hardening=+all
  10. # see ENVIRONMENT in dpkg-buildflags(1)
  11. # package maintainers to append CFLAGS
  12. #export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
  13. # package maintainers to append LDFLAGS
  14. #export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
  15. #Packagname
  16. plib_bin=libcpuid
  17. plib_dev=libcpuid-dev
  18. # main packaging script based on dh7 syntax
  19. %:
  20. # dh $@ --with autotools-dev
  21. dh $@
  22. # debmake generated override targets
  23. # This is example for Cmake (See http://bugs.debian.org/641051 )
  24. override_dh_auto_configure:
  25. libtoolize
  26. autoreconf --install
  27. dh_auto_configure