higan-libretro.SlackBuild 3.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091929394
  1. #!/bin/sh
  2. # Slackware build script for higan-libretro
  3. # Copyright 2017 orbea
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. PRGNAM=higan-libretro
  23. LIBNAM=higan_sfc_libretro
  24. BRANCH=${BRANCH:-libretro}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_git}
  27. if [ -z "$ARCH" ]; then
  28. case "$( uname -m )" in
  29. i?86) ARCH=i586 ;;
  30. arm*) ARCH=arm ;;
  31. *) ARCH=$( uname -m ) ;;
  32. esac
  33. fi
  34. CWD=$(pwd)
  35. TMP=${TMP:-/tmp/SBo}
  36. PKG=$TMP/package-$PRGNAM
  37. OUTPUT=${OUTPUT:-/tmp}
  38. LIBDIRSUFFIX=
  39. [ "$ARCH" = x86_64 ] && LIBDIRSUFFIX=64
  40. set -eu
  41. rm -rf $PKG
  42. mkdir -p $TMP $PKG $OUTPUT
  43. cd $TMP
  44. rm -rf $PRGNAM
  45. git clone --depth=1 -b $BRANCH https://gitlab.com/higan/higan.git $PRGNAM
  46. cd $PRGNAM
  47. HEAD="$(git rev-parse --short HEAD)"
  48. DATE="$(git show -s --format=%cd --date=format:%Y.%m.%d)"
  49. VERSION="${DATE}_$HEAD"
  50. chown -R root:root .
  51. find -L . \
  52. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  53. -o -perm 511 \) -exec chmod 755 {} \; -o \
  54. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  55. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  56. [ "${DEBUG:=optimize}" != optimize ] && DEBUG=debug
  57. # clang++ avoids crashes when loading content for the second time
  58. make -C higan \
  59. binary=library \
  60. compiler=clang++ \
  61. target=libretro \
  62. build=$DEBUG
  63. install -Dm0644 higan/out/$LIBNAM.so $PKG/usr/lib${LIBDIRSUFFIX}/libretro/$LIBNAM.so
  64. curl --create-dirs -o $PKG/usr/lib${LIBDIRSUFFIX}/libretro/info/$LIBNAM.info \
  65. https://raw.githubusercontent.com/libretro/libretro-super/master/dist/info/$LIBNAM.info
  66. find $PKG/usr/lib${LIBDIRSUFFIX}/libretro -mindepth 1 -type d -exec chmod 755 {} \;
  67. if [ $DEBUG = optimize ]; then
  68. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" |
  69. grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  70. fi
  71. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  72. cp -a CONTRIBUTING.md README.md $PKG/usr/doc/$PRGNAM-$VERSION
  73. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  74. mkdir -p $PKG/install
  75. cat $CWD/slack-desc > $PKG/install/slack-desc
  76. cd $PKG
  77. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-${VERSION}_$BRANCH-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}