PKGBUILD 2.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475
  1. # Partial Maintainer: nullifed <aby@pbpx.yv> [ROT13]
  2. # Maintainer NOTE: Don't expect any major update progress, at most some minor tweaks.
  3. # Contributor: Liviu Solcovenco <solcovenco dot liviu at gmail dot com>
  4. # Contributor: Philip Deljanov <philip dot deljanov at gmail dot com>
  5. # Contributor: bohoomil <bohoomil at zoho dot com>
  6. pkgname=freetype2-infinality-remix
  7. pkgver=2.13.0
  8. pkgrel=1
  9. pkgdesc="TrueType font rendering library with Infinality Remix patches"
  10. arch=(i686 x86_64)
  11. license=('GPL')
  12. url="http://www.freetype.org/"
  13. # Adding harfbuzz for improved OpenType features auto-hinting
  14. # introduces a cycle dep to harfbuzz depending on freetype wanted by upstream
  15. makedepends=('libx11' 'libpng' 'harfbuzz')
  16. install=freetype2.install
  17. source=(https://download-mirror.savannah.gnu.org/releases/freetype/freetype-${pkgver}.tar.xz{,.sig}
  18. 0001-Enable-table-validation-modules.patch
  19. 0002-infinality-2.11.1-2021.12.10.patch
  20. 0004-Enable-long-PCF-family-names.patch
  21. freetype2.sh
  22. infinality-settings.sh
  23. xft-settings.sh)
  24. sha256sums=('5ee23abd047636c24b2d43c6625dcafc66661d1aca64dec9e0d05df29592624c'
  25. 'SKIP'
  26. 'ac11a24b62a6c044cc245ea9fa2a0cbd9e2e62f2371873dd33084c28a76e7176'
  27. '6d563b1f9f9ef52379818ff3ede26b44e0b4cb6e3cf46ea44ca5d36b6d29ae9d'
  28. '54800d4da18611cf9232aad8b63d74a83153a51bb56dd39191678c738ffc8b53'
  29. 'f7f8e09c44f7552c883846e9a6a1efc50377c4932234e74adc4a8ff750606467'
  30. '1a5c12aa96e2ee66f7316b8ccb7012520b231a2d8ee21cfe4064aa28db35a57c'
  31. '4842d1461c240cd0f60a7247ee038271fdb1067107bea9024be6bdbb218d1bd4')
  32. validpgpkeys=('E30674707856409FF1948010BE6C3AAC63AD8E3F')
  33. prepare() {
  34. mv freetype-${pkgver} freetype2
  35. # Patching FreeType
  36. cd freetype2
  37. patch -Np1 -i ../0001-Enable-table-validation-modules.patch
  38. patch -Np1 -i ../0002-infinality-2.11.1-2021.12.10.patch
  39. patch -Np1 -i ../0004-Enable-long-PCF-family-names.patch
  40. }
  41. build() {
  42. cd freetype2
  43. ./configure --prefix=/usr --disable-static --with-harfbuzz --with-png
  44. make
  45. }
  46. check() {
  47. cd freetype2
  48. make -k check
  49. }
  50. package() {
  51. groups=('infinality-remix')
  52. depends=('zlib' 'bzip2' 'sh' 'libpng' 'harfbuzz')
  53. provides=("freetype2=$pkgver" 'freetype2-infinality' 'libfreetype.so')
  54. conflicts=('freetype2' 'freetype2-infinality' 'freetype2-infinality-ultimate')
  55. cd freetype2
  56. make DESTDIR="${pkgdir}" install
  57. # Disables changes to FREETYPE_PROPERTIES globally.
  58. install -Dm644 ../freetype2.sh "${pkgdir}/etc/profile.d/freetype2.sh"
  59. # Configures generic Xft hinting globally.
  60. install -Dm755 ../xft-settings.sh "${pkgdir}/etc/X11/xinit/xinitrc.d/xft-settings.sh"
  61. # Configures global default Infinality settings.
  62. install -Dm755 ../infinality-settings.sh "${pkgdir}/etc/X11/xinit/xinitrc.d/infinality-settings.sh"
  63. }