jmacs.scm 21 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578
  1. ;;; Jmacs is free software; you can redistribute it and/or modify it
  2. ;;; under the terms of the GNU General Public License as published by
  3. ;;; the Free Software Foundation; either version 3 of the License, or (at
  4. ;;; your option) any later version.
  5. ;;;
  6. ;;; Jmacs is distributed in the hope that it will be useful, but
  7. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  8. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  9. ;;; GNU General Public License for more details.
  10. ;;;
  11. ;;; You should have received a copy of the GNU General Public License
  12. ;;; along with Jmacs. If not, see <http://www.gnu.org/licenses/>.
  13. ;; This is my specific customization of Emacs
  14. ;; It loads in some specific emacs packages, and adds those as propogated
  15. ;; inputs to my emacs
  16. ;; I can add in all the optional dependencies of emacs
  17. ;; https://git.savannah.gnu.org/cgit/emacs.git/tree/INSTALL
  18. ;; change the default configure flags:
  19. ;; --with-cairo to enable cairo drawing
  20. ;; I can try using GCC to natively compile elisp!
  21. ;; http://akrl.sdf.org/gccemacs.html#orgdf63763
  22. ;; --with-nativecomp
  23. ;; there may be a nix package for this: https://github.com/NixOS/nixpkgs/issues/87400
  24. ;; https://toobnix.org/videos/watch/1f997b3c-00dc-4f7d-b2ce-74538c194fa7
  25. ;; it is being developed on a branch of the emacs tree!
  26. ;; http://git.savannah.gnu.org/cgit/emacs.git?h=feature%2Fnative-comp
  27. (define-module (gnu packages jmacs)
  28. #:use-module (guix packages)
  29. #:use-module (gnu packages)
  30. #:use-module (gnu packages aspell)
  31. #:use-module (gnu packages base)
  32. #:use-module (gnu packages code)
  33. #:use-module (gnu packages gnome-xyz)
  34. #:use-module (guix build-system emacs)
  35. #:use-module (gnu packages finance)
  36. #:use-module (gnu packages gdb)
  37. #:use-module (gnu packages mail)
  38. #:use-module (gnu packages sqlite)
  39. #:use-module (guix download) ;;so I can download the source code...
  40. #:use-module (guix git-download)
  41. #:use-module (gnu packages emacs)
  42. #:use-module (gnu packages emacs-xyz)
  43. #:use-module (gnu packages rust-apps)
  44. #:use-module ((guix licenses) #:prefix license:)
  45. )
  46. ;;(define-public emacs-aggressive-fill-paragraph
  47. ;; (package
  48. ;; (name "emacs-aggressive-fill-paragraph")
  49. ;; (version "20180910.816")
  50. ;; (source
  51. ;; (origin
  52. ;; (method url-fetch)
  53. ;; (uri (string-append
  54. ;; "https://melpa.org/packages/aggressive-fill-paragraph-"
  55. ;; version
  56. ;; ".el"))
  57. ;; (sha256
  58. ;; (base32
  59. ;; "12fi9r1wfzv8iqyzrnh82lq6793i9gxq52hk54acxskax29kmn30"))))
  60. ;; (build-system emacs-build-system)
  61. ;; (propagated-inputs `(("emacs-dash" ,emacs-dash)))
  62. ;; (home-page
  63. ;; "https://github.com/davidshepherd7/aggressive-fill-paragraph-mode")
  64. ;; (synopsis
  65. ;; "A mode to automatically keep paragraphs filled")
  66. ;; (description
  67. ;; "An Emacs minor-mode for keeping paragraphs filled in both comments and prose.")
  68. ;; (license #f)))
  69. (define-public emacs-flycheck-color-mode-line
  70. (package
  71. (name "emacs-flycheck-color-mode-line")
  72. (version "20200528.416")
  73. (source
  74. (origin
  75. (method url-fetch)
  76. (uri (string-append
  77. "https://melpa.org/packages/flycheck-color-mode-line-"
  78. version
  79. ".el"))
  80. (sha256
  81. (base32 "1ky0kzsbpb2cxdvg7miv402qglmin0grdfdwlvvq5wz5pxy3zw84"))))
  82. (build-system emacs-build-system)
  83. (propagated-inputs
  84. `(("emacs-flycheck" ,emacs-flycheck) ("emacs-dash" ,emacs-dash)))
  85. (home-page "https://github.com/flycheck/flycheck-color-mode-line")
  86. (synopsis "Change mode line color with Flycheck status")
  87. (description
  88. "Colorize the mode line according to the Flycheck status.
  89. This package provides the `flycheck-color-mode-line-mode' minor mode which
  90. changes the color of the mode line according to the status of Flycheck syntax
  91. checking.
  92. To enable this mode in Flycheck, add it to `flycheck-mode-hook':
  93. (add-hook 'flycheck-mode-hook 'flycheck-color-mode-line-mode)
  94. Thanks go to:
  95. - Thomas Järvstrand (tjarvstrand) for the initial code from the excellent
  96. EDTS package
  97. - Sebastian Wiesner (lunaryorn) for flycheck and his awesome support.
  98. ")
  99. (license #f)))
  100. (define-public emacs-flycheck-pos-tip
  101. (package
  102. (name "emacs-flycheck-pos-tip")
  103. (version "20200516.1600")
  104. (source
  105. (origin
  106. (method url-fetch)
  107. (uri (string-append
  108. "https://melpa.org/packages/flycheck-pos-tip-"
  109. version
  110. ".el"))
  111. (sha256
  112. (base32
  113. "150sadz6myaw5p5r9xym07jqfrfgipks64av7wndzqkhax8qjmhr"))))
  114. (build-system emacs-build-system)
  115. (propagated-inputs
  116. `(("emacs-flycheck" ,emacs-flycheck)
  117. ("emacs-pos-tip" ,emacs-pos-tip)))
  118. (home-page
  119. "https://github.com/flycheck/flycheck-pos-tip")
  120. (synopsis
  121. "Display Flycheck errors in GUI tooltips")
  122. (description
  123. "Provide an error display function to show errors in a tooltip.
  124. Setup
  125. (with-eval-after-load 'flycheck
  126. (flycheck-pos-tip-mode))
  127. ")
  128. (license #f)))
  129. (define-public emacs-helm-flx
  130. (package
  131. (name "emacs-helm-flx")
  132. (version "20180103.516")
  133. (source
  134. (origin
  135. (method url-fetch)
  136. (uri (string-append
  137. "https://melpa.org/packages/helm-flx-"
  138. version
  139. ".el"))
  140. (sha256
  141. (base32
  142. "0wi5xix1y5cq1v4bsz5rl6kg2axw03s5j9xad174p0mi1pqyh04x"))))
  143. (build-system emacs-build-system)
  144. (propagated-inputs
  145. `(("emacs-helm" ,emacs-helm)
  146. ("emacs-flx" ,emacs-flx)))
  147. (home-page
  148. "https://github.com/PythonNut/helm-flx")
  149. (synopsis "Sort helm candidates by flx score")
  150. (description
  151. "This package implements intelligent helm fuzzy sorting, provided by flx.")
  152. (license license:gpl3+)))
  153. (define-public emacs-all-the-icons-gnus
  154. (package
  155. (name "emacs-all-the-icons-gnus")
  156. (version "20180511.654")
  157. (source
  158. (origin
  159. (method url-fetch)
  160. (uri (string-append
  161. "https://melpa.org/packages/all-the-icons-gnus-"
  162. version
  163. ".el"))
  164. (sha256
  165. (base32
  166. "1w86rmwfljr46di2i19q2jcqp5gdsvfjim005rvzrb4lwnj5dnzb"))))
  167. (build-system emacs-build-system)
  168. (propagated-inputs
  169. `(("emacs-dash" ,emacs-dash)
  170. ("emacs-all-the-icons" ,emacs-all-the-icons)))
  171. (home-page "unspecified")
  172. (synopsis "Shows icons for in Gnus")
  173. (description
  174. "To use this package, do
  175. (require 'all-the-icons-gnus)
  176. (all-the-icons-gnus-setup)")
  177. (license #f)))
  178. (define-public emacs-evil-goggles
  179. (package
  180. (name "emacs-evil-goggles")
  181. (version "20181123.1946")
  182. (source
  183. (origin
  184. (method url-fetch)
  185. (uri (string-append
  186. "https://melpa.org/packages/evil-goggles-"
  187. version
  188. ".el"))
  189. (sha256
  190. (base32
  191. "0zrmflb6fs891dhnjqwgg3cl1rm27kdq00dbwh62vzf3kkji7mkp"))))
  192. (build-system emacs-build-system)
  193. (propagated-inputs `(("emacs-evil" ,emacs-evil)))
  194. (home-page
  195. "http://github.com/edkolev/evil-goggles")
  196. (synopsis "Add a visual hint to evil operations")
  197. (description
  198. "Add a visual hint to evil edit operations such as yank, delete,
  199. paste, etc.")
  200. (license #f)))
  201. (define-public emacs-fsm
  202. (package
  203. (name "emacs-fsm")
  204. (version "0.2.1")
  205. (source
  206. (origin
  207. (method url-fetch)
  208. (uri (string-append
  209. "https://elpa.gnu.org/packages/fsm-"
  210. version
  211. ".el"))
  212. (sha256
  213. (base32
  214. "1jyxyqdbfl8nv7c50q0sg3w5p7whp1sqgi7w921k5hfar4d11qqp"))))
  215. (build-system emacs-build-system)
  216. (home-page
  217. "http://elpa.gnu.org/packages/fsm.html")
  218. (synopsis "state machine library")
  219. (description
  220. "fsm.el is an exercise in metaprogramming inspired by gen_fsm of
  221. Erlang/OTP. It aims to make asynchronous programming in Emacs Lisp
  222. easy and fun. By \"asynchronous\" I mean that long-lasting tasks
  223. don't interfer with normal editing.")
  224. (license license:gpl3+)))
  225. (define-public emacs-jabber
  226. (package
  227. (name "emacs-jabber")
  228. (version "20180927.2325")
  229. (source
  230. (origin
  231. (method url-fetch)
  232. (uri (string-append "https://melpa.org/packages/jabber-" version ".tar"))
  233. (sha256
  234. (base32 "15s5yx0ak610yrmihn0jnr8bbygldyii9lxhhb5469j7rnxib9yx"))))
  235. (build-system emacs-build-system)
  236. (propagated-inputs `(("emacs-fsm" ,emacs-fsm) ("emacs-srv" ,emacs-srv)))
  237. (home-page "unspecified")
  238. (synopsis "A Jabber client for Emacs.")
  239. (description "No description available.")
  240. (license #f)))
  241. (define-public emacs-srv
  242. (package
  243. (name "emacs-srv")
  244. (version "20180715.1959")
  245. (source
  246. (origin
  247. (method url-fetch)
  248. (uri (string-append "https://melpa.org/packages/srv-" version ".el"))
  249. (sha256
  250. (base32 "1byxkbkmz108ps1l8zp4ij7dljzrj74b1sscn084mqpwnrf48nx6"))))
  251. (build-system emacs-build-system)
  252. (home-page "https://github.com/legoscia/srv.el")
  253. (synopsis "perform SRV DNS requests")
  254. (description
  255. "This code implements RFC 2782 (SRV records). It was originally
  256. written for jabber.el <http://emacs-jabber.sf.net>, but is now a
  257. separate package.
  258. It is used to look up hostname and port for a service at a specific
  259. domain. There might be multiple results, and the caller is supposed
  260. to attempt to connect to each hostname+port in turn. For example,
  261. to find the XMPP client service for the domain gmail.com:
  262. (srv-lookup \"_xmpp-client._tcp.gmail.com\")
  263. -> ((\"xmpp.l.google.com\" . 5222)
  264. (\"alt3.xmpp.l.google.com\" . 5222)
  265. (\"alt4.xmpp.l.google.com\" . 5222)
  266. (\"alt1.xmpp.l.google.com\" . 5222)
  267. (\"alt2.xmpp.l.google.com\" . 5222))
  268. ")
  269. (license #f)))
  270. (define-public emacs-hexrgb
  271. (package
  272. (name "emacs-hexrgb")
  273. (version "20091114.1959")
  274. (source
  275. (origin
  276. (method git-fetch)
  277. (uri (git-reference
  278. (url "https://notabug.org/jbranso/hexrgb.el.git")
  279. (commit "2ca08804e2b8718df6207fd35647d26262e48e11")))
  280. (sha256
  281. (base32 "10siq0pi7fmqbr05yvfgn8f7xapkfjb3xian90mv1zmrp47ilmir"))))
  282. (build-system emacs-build-system)
  283. (home-page "https://notabug.org/jbranso/hexrgb.el")
  284. (synopsis "Functions to manipulate colors, including RGB hex strings for Emacs.")
  285. (description
  286. "Functions to manipulate colors, including RGB hex strings for Emacs. It is used in jabber.el.")
  287. (license #f)))
  288. ;;(define-public my-emacs-ledger-mode
  289. ;; (package
  290. ;; (name "emacs-ledger-mode")
  291. ;; (version "20200530.1710")
  292. ;; (source
  293. ;; (origin
  294. ;; (method url-fetch)
  295. ;; (uri (string-append
  296. ;; "https://melpa.org/packages/ledger-mode-"
  297. ;; version
  298. ;; ".tar"))
  299. ;; (sha256
  300. ;; (base32
  301. ;; "1843pa6fkf76v44nwignwwn1h48m01l5g5nmrx7rynmshi95nkj0"))))
  302. ;; (build-system emacs-build-system)
  303. ;; (home-page "unspecified")
  304. ;; (synopsis
  305. ;; "Helper code for use with the \"ledger\" command-line tool")
  306. ;; (description
  307. ;; "Most of the general ledger-mode code is here.
  308. ;;")
  309. ;; (license #f)))
  310. (define-public emacs-scss-mode
  311. (package
  312. (name "emacs-scss-mode")
  313. (version "20180123.1708")
  314. (source
  315. (origin
  316. (method url-fetch)
  317. (uri (string-append
  318. "https://melpa.org/packages/scss-mode-"
  319. version
  320. ".el"))
  321. (sha256
  322. (base32
  323. "15305g09kaw813yib6l1q0ihwqw3hpbm3zg1v5rmc5x2dvcc61bj"))))
  324. (build-system emacs-build-system)
  325. (home-page "https://github.com/antonj/scss-mode")
  326. (synopsis "Major mode for editing SCSS files")
  327. (description
  328. "Command line utility sass is required, see http://sass-lang.com/
  329. To install sass:
  330. gem install sass
  331. Also make sure sass location is in emacs PATH, example:
  332. (setq exec-path (cons (expand-file-name \"~/.gem/ruby/1.8/bin\") exec-path))
  333. or customize `scss-sass-command' to point to your sass executable.
  334. ")
  335. (license #f)))
  336. (define-public emacs-smart-comment
  337. (package
  338. (name "emacs-smart-comment")
  339. (version "20160322.1839")
  340. (source
  341. (origin
  342. (method url-fetch)
  343. (uri (string-append
  344. "https://melpa.org/packages/smart-comment-"
  345. version
  346. ".el"))
  347. (sha256
  348. (base32
  349. "03cqfwk7nxl0bj1cj1kv3hrd0811w82q0lccqxl9l8iqlx5m27yz"))))
  350. (build-system emacs-build-system)
  351. (home-page "unspecified")
  352. (synopsis "smarter commenting")
  353. (description
  354. "Code gets rewritten when refactoring to accomidate for new features or
  355. when fixing bugs. An approach used by many developers is to disable a
  356. piece of code with comments, then rewrite an improved version below,
  357. test that is works and then delete the commented code. smart-comment
  358. makes this and similair workflows much swifter.
  359. smart-comment is implemented on top of the commenting functions built
  360. in to Emacs. It is meant to replace `comment-dwim` as the function you
  361. bind to `M-;`.
  362. It triggers different comment actions taking the current location of
  363. the point into acount. Commenting out lines of code is faster.
  364. Commented lines can be marked for later deletion and then all removed
  365. with a single command.
  366. ")
  367. (license #f)))
  368. (define-public emacs-vala-mode
  369. (package
  370. (name "emacs-vala-mode")
  371. (version "20201218.2109")
  372. (source
  373. (origin
  374. (method url-fetch)
  375. (uri (string-append
  376. "https://melpa.org/packages/vala-mode-"
  377. version
  378. ".el"))
  379. (sha256
  380. (base32
  381. "0y0j4mxiwddyyrmglfyyilaivchgj6v2x8w5qz0ik7c2xr84apnp"))))
  382. (build-system emacs-build-system)
  383. (home-page "unspecified")
  384. (synopsis "Vala mode derived mode")
  385. (description
  386. "
  387. See http://live.gnome.org/Vala for details about Vala language.
  388. This mode was based on Dylan Moonfire's csharp-mode.
  389. This is a copy of the function in cc-mode which is used to handle
  390. the eval-when-compile which is needed during other times.
  391. ")
  392. (license #f)))
  393. (define-public jmacs
  394. (package
  395. (inherit emacs)
  396. (name "jmacs")
  397. ;; (inputs
  398. ;; `(("gnu-make" ,gnu-make)))
  399. (propagated-inputs ;;installed in the store and present in the profile
  400. `(("aspell" ,aspell)
  401. ("aspell-dict-en" ,aspell-dict-en)
  402. ("emacs-2048-game" ,emacs-2048-game)
  403. ("emacs-async" ,emacs-async)
  404. ("emacs-anzu" ,emacs-anzu)
  405. ("emacs-all-the-icons" ,emacs-all-the-icons)
  406. ("emacs-all-the-icons-dired" ,emacs-all-the-icons-dired)
  407. ("emacs-all-the-icons-gnus" ,emacs-all-the-icons-gnus)
  408. ("emacs-alert" ,emacs-alert)
  409. ;; ("emacs-aggressive-fill-paragraph" ,emacs-aggressive-fill-paragraph)
  410. ("emacs-aggressive-indent" ,emacs-aggressive-indent)
  411. ("emacs-ag" ,emacs-ag)
  412. ("emacs-ace-window" ,emacs-ace-window)
  413. ("emacs-avy" ,emacs-avy)
  414. ;; ("emacs-bug-hunter" ,emacs-bug-hunter)
  415. ("emacs-build-farm" ,emacs-build-farm)
  416. ("emacs-bbdb" ,emacs-bbdb)
  417. ("emacs-company" ,emacs-company)
  418. ("emacs-daemons" ,emacs-daemons)
  419. ;; ;; list library
  420. ("emacs-dash" ,emacs-dash)
  421. ;;("emacs-dashboard" ,emacs-dashboard)
  422. ;; ;; show the diffs in a git buffer on the fringe of a buffer.
  423. ("emacs-diff-hl" ,emacs-diff-hl)
  424. ("emacs-dumb-jump" ,emacs-dumb-jump)
  425. ("emacs-ebdb" ,emacs-ebdb)
  426. ("emacs-company-ebdb" ,emacs-company-ebdb)
  427. ("emacs-elfeed" ,emacs-elfeed)
  428. ("emacs-emmet-mode" ,emacs-emmet-mode)
  429. ;;("emacs-emms" ,emacs-emms)
  430. ("emacs-evil" ,emacs-evil)
  431. ("emacs-evil-args" ,emacs-evil-args)
  432. ("emacs-evil-commentary" ,emacs-evil-commentary)
  433. ("emacs-evil-goggles" ,emacs-evil-goggles)
  434. ("emacs-evil-surround" ,emacs-evil-surround)
  435. ;; this lets you use the debian pastebin!!!
  436. ("emacs-debpaste" ,emacs-debpaste)
  437. ("emacs-debbugs" ,emacs-debbugs)
  438. ("emacs-f" ,emacs-f)
  439. ("emacs-f3" ,emacs-f3)
  440. ("emacs-fish-completion" ,emacs-fish-completion)
  441. ("emacs-flycheck" ,emacs-flycheck)
  442. ("emacs-flycheck-pos-tip" ,emacs-flycheck-pos-tip)
  443. ("emacs-flycheck-color-mode-line" ,emacs-flycheck-color-mode-line)
  444. ("emacs-flycheck-guile" ,emacs-flycheck-guile)
  445. ("emacs-flx" ,emacs-flx)
  446. ("emacs-geiser" ,emacs-geiser)
  447. ("emacs-geiser-guile" ,emacs-geiser-guile)
  448. ("emacs-gif-screencast" ,emacs-gif-screencast)
  449. ("emacs-git-timemachine" ,emacs-git-timemachine)
  450. ("emacs-gitpatch" ,emacs-gitpatch)
  451. ("emacs-ggtags" ,emacs-ggtags)
  452. ("emacs-gnuplot" ,emacs-gnuplot)
  453. ("emacs-gnus-harvest" ,emacs-gnus-harvest)
  454. ("emacs-gtk-look" ,emacs-gtk-look)
  455. ;;("emacs-guix" ,emacs-guix)
  456. ("emacs-helm" ,emacs-helm)
  457. ;;("emacs-helm-flx" ,emacs-helm-flx)
  458. ("emacs-helm-ag" ,emacs-helm-ag)
  459. ("emacs-helm-gtags" ,emacs-helm-gtags)
  460. ("emacs-helm-mu" ,emacs-helm-mu)
  461. ("emacs-helm-projectile" ,emacs-helm-projectile)
  462. ("emacs-helm-swoop" ,emacs-helm-swoop)
  463. ("emacs-helm-system-packages" ,emacs-helm-system-packages)
  464. ("emacs-hl-todo" ,emacs-hl-todo)
  465. ("emacs-json-mode" ,emacs-json-mode)
  466. ("emacs-jabber" ,emacs-jabber)
  467. ("emacs-hexrgb" ,emacs-hexrgb)
  468. ("emacs-js2-mode" ,emacs-js2-mode)
  469. ;;("my-emacs-ledger-mode" ,my-emacs-ledger-mode)
  470. ;; emacs vala-mode is apparently NOT compiling now
  471. ;; https://github.com/rrthomas/vala-mode/tree/d696a8177e94c81ea557ad364a3b3dcc3abbc50f
  472. ;; In toplevel form:
  473. ;; vala-mode.el:270:8:Warning: reference to free variable
  474. ;; ‘vala-multiline-strings’
  475. ;; Eval error in the ‘c-lang-defconst’ for ‘c-multiline-string-start-char’ in vala-mode:
  476. ;; Symbol’s value as variable is void: vala-multiline-strings
  477. ;; command "/gnu/store/6kfvm6qhm5g875jp34x84bgiffhwbyn9-emacs-minimal-27.2/bin/emacs" "--quick" "--batch" "--eval=(eval '(progn (setq byte-compile-debug t) (byte-recompile-directory (file-name-as-directory \"/gnu/store/s8dhwn4q70yl8dwcg29v7n5hmzc9m24v-emacs-vala-mode-20201218.2109/share/emacs/site-lisp/vala-mode-20201218.2109\") 0 1)) t)" failed with status 255
  478. ;; I could try this vala mode https://www.emacswiki.org/emacs/vala-mode.el
  479. ;; this vala mode works
  480. ;; https://wiki.gnome.org/Projects/Vala/Emacs this works
  481. ;; this youtube guide shows you how to learn
  482. ;; vala https://www.youtube.com/watch?v=0R8gzwiR9sI&list=PLriKzYyLb28mn2lS3c5yqMHgLREi7kR9-&index=5
  483. ;; ("emacs-vala-mode" ,emacs-vala-mode)
  484. ;; ("emacs-lsp-mode" ,emacs-lsp-mode)
  485. ;; ("vala-language-server" ,vala-language-server)
  486. ("emacs-lua-mode" ,emacs-lua-mode)
  487. ("emacs-magit" ,emacs-magit)
  488. ("emacs-magit-popup" ,emacs-magit-popup)
  489. ("emacs-magit-todos" ,emacs-magit-todos)
  490. ("emacs-magit-org-todos-el" ,emacs-magit-org-todos-el)
  491. ("emacs-mbsync" ,emacs-mbsync)
  492. ("emacs-markdown-mode" ,emacs-markdown-mode)
  493. ("emacs-mu4e-alert" ,emacs-mu4e-alert)
  494. ("emacs-nov-el" ,emacs-nov-el)
  495. ("emacs-nginx-mode" ,emacs-nginx-mode)
  496. ("emacs-org" ,emacs-org)
  497. ("emacs-org-bullets" ,emacs-org-bullets)
  498. ("emacs-org-contrib" ,emacs-org-contrib)
  499. ("emacs-pdf-tools" ,emacs-pdf-tools)
  500. ("emacs-page-break-lines" ,emacs-page-break-lines)
  501. ;; todo make this emacs-parinfer-mode@0.4.10
  502. ("emacs-paredit" ,emacs-paredit)
  503. ("emacs-parinfer-mode" ,emacs-parinfer-mode)
  504. ("emacs-projectile" ,emacs-projectile)
  505. ;; ;; display CSS #000000 as black
  506. ("emacs-rainbow-mode" ,emacs-rainbow-mode)
  507. ("emacs-s" ,emacs-s)
  508. ;;("emacs-smart-mode-line" ,emacs-smart-mode-line)
  509. ("emacs-scss-mode" ,emacs-scss-mode)
  510. ("emacs-smart-comment" ,emacs-smart-comment)
  511. ("emacs-smartparens" ,emacs-smartparens)
  512. ("emacs-transmission" ,emacs-transmission)
  513. ("emacs-which-key" ,emacs-which-key)
  514. ;;("emacs-wget" ,emacs-wget)
  515. ("emacs-web-mode" ,emacs-web-mode)
  516. ("emacs-use-package" ,emacs-use-package)
  517. ("emacs-yasnippet" ,emacs-yasnippet)
  518. ("emacs-yasnippet-snippets" ,emacs-yasnippet-snippets)
  519. ("emacs-youtube-dl" ,emacs-youtube-dl)
  520. ("emacs-zenurnburn-theme" ,emacs-zenburn-theme)
  521. ("gdb" ,gdb)
  522. ("ledger" ,ledger)
  523. ;;("notmuch" ,notmuch)
  524. ("ripgrep" ,ripgrep)
  525. ("emacs-rg" ,emacs-rg)
  526. ("emacs-deadgrep" ,emacs-deadgrep)
  527. ("the-silver-searcher" ,the-silver-searcher)
  528. ("sqlite" ,sqlite)))))
  529. ;; uncomment this to make this work via install file
  530. ;; jmacs
  531. ;; maybe I should use this one day
  532. ;; "emacs-znc"
  533. ;; https://github.com/sshirokov/ZNC.el
  534. ;; znc