#153 email messages body lack plain text part

Closed
opened 1 year ago by cage · 9 comments
cage commented 1 year ago

Hello,

i receive issues messages and comments on issues via email from this instance of gogs. That is OK of course, but the format of the message (the Content-Type) is html (version 5 i think).

This is very uncomfortable for people like me that uses a text mail client (like mutt). I know i could write a filter in my procmail for that but i think would be great if this kind of mail used a plain text format or a multipart with both html and text.

Bye! C.

Hello, i receive issues messages and comments on issues via email from this instance of gogs. That is OK of course, but the format of the message (the Content-Type) is html (version 5 i think). This is very uncomfortable for people like me that uses a text mail client (like mutt). I know i could write a filter in my procmail for that but i think would be great if this kind of mail used a plain text format or a multipart with both html and text. Bye! C.
zPlus commented 1 year ago

The templates seem to be all located here and they all look like HTML files. I've also looked inside app.ini but I can't see any settings about this. My guess is that emails are only sent in HTML form.

EDIT: opened upstream

The templates seem to be all located [here](https://notabug.org/hp/gogs/src/master/templates/mail) and they all look like HTML files. I've also looked inside `app.ini` but I can't see any settings about this. My guess is that emails are only sent in HTML form. EDIT: [opened upstream](https://github.com/gogits/gogs/issues/4779)
zPlus commented 1 year ago

Sorry, I could be wrong. I've just found this option in app.ini under [mailer], which if switched to true could probably fix this issue.

Sorry, I could be wrong. I've just found [this option](https://notabug.org/hp/gogs/src/master/conf/app.ini#L250) in `app.ini` under `[mailer]`, which if switched to `true` could probably fix this issue.
cage commented 1 year ago
Poster

Hi!

Thank you for investigate the problem!

Bye. C.

Hi! Thank you for investigate the problem! Bye. C.

the title: "email message in html format" poses this as a bug but that is merely describing the expected normal behavior - the problem would be that it sends no actual message text - a title such as: "email messages have empty plain text body" would be more descriptive of the problem

i agree though it is very naive (ignorant even) to send email with an empty text body but i do see it fairly often - i would actually consider this to be a bug even though it is the intended normal behavior - it is at the least, a glaring oversight

HTML email is for marketing cat food - notabug surely does not need it - the simplest thing for notabug would be just to set that switch zPlus found and send plain text only

the title: "email message in html format" poses this as a bug but that is merely describing the expected normal behavior - the problem would be that it sends no actual message text - a title such as: "email messages have empty plain text body" would be more descriptive of the problem i agree though it is very naive (ignorant even) to send email with an empty text body but i do see it fairly often - i would actually consider this to be a bug even though it is the intended normal behavior - it is at the least, a glaring oversight HTML email is for marketing cat food - notabug surely does not need it - the simplest thing for notabug would be just to set that switch zPlus found and send plain text only
cage commented 1 year ago
Poster

Hi!

@bill-auger Good point! I changed the title as you suggested, hope this is more informative.

Bye!

C.

Hi! @bill-auger Good point! I changed the title as you suggested, hope this is more informative. Bye! C.

yet another important issue completely ignored by upstream - not so much as an acknowledgement by a maintainer

yet another important issue completely ignored by upstream - not so much as an acknowledgement by a maintainer
cage commented 2 months ago
Poster

fortunately seems to me that this problem has been fixed, mails have a text part.

If confirmed i would close that issue.

Bye. C.

fortunately seems to me that this problem has been fixed, mails have a text part. If confirmed i would close that issue. Bye. C.

Yeah, I fixed that a couple of days ago. Thanks for confirming

Yeah, I fixed that a couple of days ago. Thanks for confirming
cage commented 2 months ago
Poster

Very well!

Thank you for your work!

C.

Very well! Thank you for your work! C.
Sign in to join this conversation.
No Milestone
No assignee
4 Participants
Loading...
Cancel
Save
There is no content yet.