#145 Basic functionality needs JavaScript

Open
opened 4 months ago by cafe · 15 comments

Some users cannot use JavaScript, even if it is free. Tor users, etc.

The core site should not need JavaScript. Registration, repository creation, issues, pull requests, etc. Most already work, but the edges are rough.

For example, the link to make a repo is behind a JavaScript menu. But if the link is accessed directly somehow, it works.

Using

Some users cannot use JavaScript, even if it is free. Tor users, etc. The core site should not need JavaScript. Registration, repository creation, issues, pull requests, etc. Most already work, but the edges are rough. For example, the link to make a repo is behind a JavaScript menu. But if the link is accessed directly somehow, it works. Using <noscript> alternatives on critical areas is probably good. Thanks!
zPlus commented 4 months ago

Yes Gogs has a couple of menus that, unfortunately, only work with JavaScript. This is a problem indeed, but I think the best option is to open the issue upstream (to Gogs itself) since this is not something specific to NotABug.

Anyway, the website works without JavaScript, but like you said some URLs must be typed manually because they're only available in one of those menu (that require JavaScript to be opened).

For example, the link to make a repo is behind a JavaScript menu.

In your dashboard, next to "My Repositories" you can find a + sign. If you click it, you can create a new repository this way.

Registration, repository creation, issues; these work without JavaScript.

Yes Gogs has a couple of menus that, unfortunately, only work with JavaScript. This is a problem indeed, but I think the best option is to open the issue upstream (to Gogs itself) since this is not something specific to NotABug. Anyway, the website works without JavaScript, but like you said some URLs must be typed manually because they're only available in one of those menu (that require JavaScript to be opened). > For example, the link to make a repo is behind a JavaScript menu. In your dashboard, next to "My Repositories" you can find a `+` sign. If you click it, you can create a new repository this way. Registration, repository creation, issues; these work without JavaScript.
Cafe Beverage commented 4 months ago
Poster

OK, thanks. I did not notice that + before because of the font.

OK, thanks. I did not notice that + before because of the font.

@hp this issue can probably be closed also - unless someone knows of another critical feature that requires javascript

@hp this issue can probably be closed also - unless someone knows of another critical feature that requires javascript
zPlus commented 2 months ago

The only "critical" features that require javascript are

  • create new organization
  • create new mirror
  • change user settings
  • logout

however, all of these work if you type the correct URLs. The problem is that they are not accessible from the UI because the only way to get to those pages is from the menu at the top (which requires javascript). There are some tricks to achieve CSS/HTML-only dropdown menus, as shown by @jorgesumle here. But it's better to move this feature request upstream anyway... gogs and gitea. Interestingly, Gitea seems to work even worse than Gogs without javascript.

The only "critical" features that require javascript are - create new organization - create new mirror - change user settings - logout **however, all of these work if you type the correct URLs**. The problem is that they are not accessible from the UI because the only way to get to those pages is from the menu at the top (which requires javascript). There are some tricks to achieve CSS/HTML-only dropdown menus, as shown by @jorgesumle [here](https://www.freakspot.net/barra-de-navegacion-de-bootstrap-sin-javascript-en.html). But it's better to move this feature request upstream anyway... [gogs](https://github.com/gogits/gogs/issues/4778) and [gitea](https://github.com/go-gitea/gitea/issues/2527). Interestingly, Gitea seems to work even worse than Gogs without javascript.

proposed fix at PR #151

proposed fix at PR #151
zPlus commented 2 months ago

BTW my links to Gogs/Gitea in my last comment, are actual links to issues that I've created. But my account was flagged as spam so they're hidden.

BTW my links to Gogs/Gitea in my last comment, are actual links to issues that I've created. But my account was flagged as spam so they're hidden.

@zPlus - why were they flagged as spam? did github do that or did gogs and gitea despise the suggestion?

@zPlus - why were they flagged as spam? did github do that or did gogs and gitea despise the suggestion?
zPlus commented 2 months ago

why were they flagged as spam?

I guess either because of my username, or the fact that I posted the same issue verbatim to both gogs and gitea.

did github do that or did gogs and gitea despise the suggestion?

I'm 90% confident I was flagged by github (maybe some bot), because the issue was legit.

> why were they flagged as spam? I guess either because of my username, or the fact that I posted the same issue verbatim to both gogs and gitea. > did github do that or did gogs and gitea despise the suggestion? I'm 90% confident I was flagged by github (maybe some bot), because the issue was legit.

well it's fixed now - @hp merged the PR #151

well it's fixed now - @hp merged the PR #151
zPlus commented 2 months ago
[Not solved yet](https://notabug.org/hp/gogs/pulls/151#issuecomment-6042).

PR #152 was just merged it seems to be behaving as expected now

can close this issue?

PR #152 was just merged it seems to be behaving as expected now can close this issue?
zPlus commented 2 months ago

Yes I think this can be closed as fixed.

Yes I think this can be closed as fixed.

No. The issue and pull request pages have some dropdowns which don't work without JS. Also, the branch selectors.

No. The issue and pull request pages have some dropdowns which don't work without JS. Also, the branch selectors.

Pull requests for Gogs and for Gitea were created. After it gets merged, we should replace the patch with the code from upstream. It was merged in Gitea, but Gogs is slower, so we must wait.

Pull requests [for Gogs](https://github.com/gogits/gogs/pull/4780) and [for Gitea](https://github.com/go-gitea/gitea/pull/2541) were created. After it gets merged, we should replace the patch with the code from upstream. It was merged in Gitea, but Gogs is slower, so we must wait.
zPlus commented 2 months ago

Yeah, Gogs is moving really really slowly...

Yeah, Gogs is moving really really slowly...
Sign in to join this conversation.
No Milestone
No assignee
4 Participants
Loading...
Cancel
Save
There is no content yet.