rules 1.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293
  1. #!/usr/bin/make -f
  2. # -*- makefile -*-
  3. # Sample debian/rules that uses debhelper.
  4. # This file was originally written by Joey Hess and Craig Small.
  5. # As a special exception, when this file is copied by dh-make into a
  6. # dh-make output file, you may use that output file without restriction.
  7. # This special exception was added by Craig Small in version 0.37 of dh-make.
  8. # Uncomment this to turn on verbose mode.
  9. #export DH_VERBOSE=1
  10. PACKAGE = cvm
  11. configure: configure-stamp
  12. configure-stamp:
  13. dh_testdir
  14. # Add here commands to configure the package.
  15. qmake
  16. touch configure-stamp
  17. build: build-stamp
  18. build-stamp: configure-stamp
  19. dh_testdir
  20. # Add here commands to compile the package.
  21. $(MAKE)
  22. #docbook-to-man debian/$(PACKAGE).sgml > $(PACKAGE).1
  23. touch $@
  24. clean:
  25. dh_testdir
  26. dh_testroot
  27. rm -f build-stamp configure-stamp
  28. # Add here commands to clean up after the build process.
  29. -$(MAKE) clean
  30. dh_clean
  31. install: build
  32. dh_testdir
  33. dh_testroot
  34. dh_clean -k
  35. dh_installdirs
  36. # Add here commands to install the package into debian/$(PACKAGE).
  37. $(MAKE) INSTALL_ROOT="$(CURDIR)"/debian/$(PACKAGE) install
  38. # Build architecture-independent files here.
  39. binary-indep: build install
  40. # We have nothing to do by default.
  41. # Build architecture-dependent files here.
  42. binary-arch: build install
  43. dh_testdir
  44. dh_testroot
  45. dh_installchangelogs
  46. dh_installdocs
  47. dh_installexamples
  48. # dh_install
  49. # dh_installmenu
  50. # dh_installdebconf
  51. # dh_installlogrotate
  52. # dh_installemacsen
  53. # dh_installpam
  54. # dh_installmime
  55. # dh_python
  56. # dh_installinit
  57. # dh_installcron
  58. # dh_installinfo
  59. dh_installman
  60. dh_link
  61. dh_strip
  62. dh_compress
  63. dh_fixperms
  64. # dh_perl
  65. # dh_makeshlibs
  66. dh_installdeb
  67. ## dh_shlibdeps
  68. dh_gencontrol
  69. dh_md5sums
  70. dh_builddeb
  71. binary: binary-indep binary-arch
  72. .PHONY: build clean binary-indep binary-arch binary install configure