qt5ct-1.8.ebuild 1.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354
  1. # Copyright 1999-2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit qmake-utils
  5. DESCRIPTION="Qt5 configuration tool, similar to qtconfig for Qt4"
  6. HOMEPAGE="https://sourceforge.net/projects/qt5ct/"
  7. SRC_URI="https://download.sourceforge.net/qt5ct/${P}.tar.bz2"
  8. LICENSE="BSD-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~arm ~ppc64 x86"
  11. IUSE="dbus"
  12. RDEPEND="
  13. dev-qt/qtconcurrent:5
  14. dev-qt/qtcore:5
  15. dev-qt/qtgui:5=
  16. dev-qt/qtwidgets:5
  17. dbus? (
  18. dev-qt/qtdbus:5
  19. dev-qt/qtgui:5=[dbus]
  20. )
  21. "
  22. DEPEND="${RDEPEND}"
  23. BDEPEND="
  24. dev-qt/linguist-tools:5
  25. dev-qt/qtpaths:5
  26. "
  27. src_configure() {
  28. eqmake5 $(usex dbus '' DISABLE_DBUS=1)
  29. }
  30. src_install() {
  31. emake INSTALL_ROOT="${D}" install
  32. newenvd - 98qt5ct <<< 'QT_QPA_PLATFORMTHEME=qt5ct'
  33. }
  34. pkg_postinst() {
  35. if [[ -z ${REPLACING_VERSIONS} ]]; then
  36. ewarn "qt5ct configuration won't be applied to the currently running sessions."
  37. ewarn "Please relogin."
  38. fi
  39. if ! has_version 'dev-qt/qtsvg:5'; then
  40. elog
  41. elog "For SVG icon themes, please install 'dev-qt/qtsvg:5'."
  42. elog
  43. fi
  44. }