PKGBUILD 1.9 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556
  1. # Maintainer: caryoscelus <caryoscelus at gmx dot com>
  2. # Contributor: redfish <redfish at galactica dot pw>
  3. # Contributor: Lothar_m <lothar_m at riseup dot net>
  4. pkgname='zeronet-conservancy'
  5. _gitname='zeronet-conservancy'
  6. _gitroot='https://github.com/zeronet-conservancy/zeronet-conservancy.git'
  7. pkgver=0.7.10
  8. pkgrel=1
  9. arch=('any')
  10. url='https://github.com/zeronet-conservancy/zeronet-conservancy/'
  11. depends=('python' 'python-gevent>=1.1.0' 'python-gevent-websocket'
  12. 'python-msgpack>=0.4.4' 'python-websocket-client' 'python-rsa'
  13. 'python-pysocks' 'python-pyasn1' 'python-pyasn1-modules'
  14. 'python-bitcoinlib'
  15. 'python-pyaes'
  16. 'geoip2-database'
  17. 'python-defusedxml'
  18. 'python-rich'
  19. 'python-base58' 'python-merkletools'
  20. 'python-requests'
  21. )
  22. optdepends=('tor: anonymity'
  23. 'namecoin-core: local name resolution')
  24. makedepends=('git')
  25. checkdepends=('python-pytest' 'python-mock')
  26. license=('GPL3')
  27. pkgdesc="modern client for decentralized p2p web platform 0net"
  28. provides=(zeronet)
  29. conflicts=(zeronet)
  30. source=("git+https://github.com/zeronet-conservancy/zeronet-conservancy.git#tag=v${pkgver}"
  31. "zeronet.conf"
  32. "zeronet.service")
  33. install="zeronet.install"
  34. backup=("etc/zeronet.conf")
  35. options=(!strip) # attempt to strip binaries fromA dependent libs fial
  36. package() {
  37. cd "$srcdir/$_gitname"
  38. mkdir -p "$pkgdir/opt/zeronet"
  39. # There is no setup.py shipped, so brute-force copy
  40. cp -a "$srcdir/$_gitname/." "$pkgdir/opt/zeronet/"
  41. install -D -m644 "$srcdir/zeronet.conf" "$pkgdir/etc/zeronet.conf"
  42. install -D -m644 "$srcdir/zeronet.service" "$pkgdir/usr/lib/systemd/system/zeronet.service"
  43. # install license
  44. install -D -m644 "$srcdir/$_gitname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
  45. }
  46. sha256sums=('SKIP'
  47. 'ea735e82dbb10a2c1fda7abfeb2f38c2429044d8254f9e2396c50cecb6f778f8'
  48. '2ee64a1b671a49a1626901a11d4d7fa338c77cb9b7c9facd2f56b087a4a0bb83')