onc-rpc.scm 5.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2014, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
  3. ;;; Copyright © 2016 John Darrington <jmd@gnu.org>
  4. ;;; Copyright © 2017, 2018 Leo Famulari <leo@famulari.name>
  5. ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
  6. ;;;
  7. ;;; This file is part of GNU Guix.
  8. ;;;
  9. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  10. ;;; under the terms of the GNU General Public License as published by
  11. ;;; the Free Software Foundation; either version 3 of the License, or (at
  12. ;;; your option) any later version.
  13. ;;;
  14. ;;; GNU Guix is distributed in the hope that it will be useful, but
  15. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  16. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  17. ;;; GNU General Public License for more details.
  18. ;;;
  19. ;;; You should have received a copy of the GNU General Public License
  20. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  21. (define-module (gnu packages onc-rpc)
  22. #:use-module (guix licenses)
  23. #:use-module (guix packages)
  24. #:use-module (guix download)
  25. #:use-module (gnu packages)
  26. #:use-module (gnu packages autotools)
  27. #:use-module (gnu packages gettext)
  28. #:use-module (gnu packages kerberos)
  29. #:use-module (gnu packages pkg-config)
  30. #:use-module (guix build-system gnu))
  31. (define-public libtirpc
  32. (package
  33. (name "libtirpc")
  34. (version "1.0.3")
  35. (source (origin
  36. (method url-fetch)
  37. (uri (string-append "mirror://sourceforge/libtirpc/libtirpc/"
  38. version "/libtirpc-"
  39. version ".tar.bz2"))
  40. (sha256
  41. (base32
  42. "0ppxl3k3nsz0qdakq844i2kj4fvh9h937lhx26bgmpmxq67sghw6"))))
  43. (build-system gnu-build-system)
  44. (arguments
  45. `(#:phases
  46. (modify-phases %standard-phases
  47. (add-after 'unpack 'remote-dangling-symlink
  48. (lambda _
  49. (substitute* '("man/netconfig.5"
  50. "man/getnetconfig.3t"
  51. "man/getnetpath.3t"
  52. "man/rpc.3t"
  53. "src/getnetconfig.c"
  54. "tirpc/netconfig.h")
  55. (("/etc/netconfig") (string-append %output "/etc/netconfig")))
  56. ;; Remove the dangling symlinks since it breaks the
  57. ;; 'patch-source-shebangs' file tree traversal.
  58. (delete-file "INSTALL")
  59. #t)))))
  60. (inputs `(("mit-krb5" ,mit-krb5)))
  61. (home-page "https://sourceforge.net/projects/libtirpc/")
  62. (synopsis "Transport-independent Sun/ONC RPC implementation")
  63. (description
  64. "This package provides a library that implements the Sun/ONC RPC (remote
  65. procedure calls) protocol in a transport-independent manner. It supports both
  66. IPv4 and IPv6. ONC RPC is notably used by the network file system (NFS).")
  67. (license bsd-3)))
  68. (define-public rpcbind
  69. (package
  70. (name "rpcbind")
  71. (version "0.2.4")
  72. (source
  73. (origin
  74. (method url-fetch)
  75. (uri (string-append "mirror://sourceforge/" name "/" name "/"
  76. version "/"
  77. name "-" version ".tar.bz2"))
  78. (patches (search-patches "rpcbind-CVE-2017-8779.patch"))
  79. (sha256
  80. (base32
  81. "0rjc867mdacag4yqvs827wqhkh27135rp9asj06ixhf71m9rljh7"))))
  82. (build-system gnu-build-system)
  83. (arguments
  84. `(#:configure-flags
  85. `("--with-systemdsystemunitdir=no" "--enable-warmstarts")))
  86. (inputs
  87. `(("libnsl" ,libnsl)
  88. ("libtirpc" ,libtirpc)))
  89. (native-inputs
  90. `(("pkg-config" ,pkg-config)))
  91. (home-page "http://rpcbind.sourceforge.net/")
  92. (synopsis "Server to convert RPC program numbers into universal addresses")
  93. (description
  94. "@command{Rpcbind} is a server that converts RPC program numbers into
  95. universal addresses.")
  96. (license bsd-3)))
  97. (define-public libnsl
  98. (package
  99. (name "libnsl")
  100. (version "1.2.0")
  101. (source (origin
  102. (method url-fetch)
  103. (uri (string-append "https://github.com/thkukuk/libnsl/archive/v"
  104. version ".tar.gz"))
  105. (file-name (string-append name "-" version ".tar.gz"))
  106. (sha256
  107. (base32
  108. "1y6kmxmv1difzvdhx7grqzw0j2v2b74mg4kjb803m8jcgkqqx8m5"))))
  109. (build-system gnu-build-system)
  110. (native-inputs
  111. `(("autoconf" ,autoconf)
  112. ("automake" ,automake)
  113. ("gettext" ,gettext-minimal)
  114. ("libtool" ,libtool)
  115. ("pkg-config" ,pkg-config)))
  116. (inputs
  117. `(("libtirpc" ,libtirpc)))
  118. (synopsis "Public client interface for NIS(YP) and NIS+")
  119. (description "Libnsl is the public client interface for the Network
  120. Information Service / Yellow Pages (NIS/YP) and NIS+. It includes IPv6 support.
  121. This library was part of glibc < 2.26, but is now distributed separately.")
  122. (home-page "https://github.com/thkukuk/libnsl")
  123. ;; The package is distributed under the LGPL 2.1. Some files in
  124. ;; 'src/nisplus/' are LGPL 2.1+, and some files in 'src/rpcsvc/' are BSD-3.
  125. (license lgpl2.1)))