123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213 |
- ;;; GNU Guix --- Functional package management for GNU
- ;;; Copyright © 2014 Cyrill Schenkel <cyrill.schenkel@gmail.com>
- ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
- ;;; Copyright © 2015, 2016 David Thompson <davet@gnu.org>
- ;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
- ;;; Copyright © 2017 Mike Gerwitz <mtg@gnu.org>
- ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
- ;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
- ;;;
- ;;; This file is part of GNU Guix.
- ;;;
- ;;; GNU Guix is free software; you can redistribute it and/or modify it
- ;;; under the terms of the GNU General Public License as published by
- ;;; the Free Software Foundation; either version 3 of the License, or (at
- ;;; your option) any later version.
- ;;;
- ;;; GNU Guix is distributed in the hope that it will be useful, but
- ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
- ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- ;;; GNU General Public License for more details.
- ;;;
- ;;; You should have received a copy of the GNU General Public License
- ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
- (define-module (gnu packages node)
- #:use-module ((guix licenses) #:select (expat))
- #:use-module (guix packages)
- #:use-module (guix derivations)
- #:use-module (guix download)
- #:use-module (guix build-system gnu)
- #:use-module (gnu packages)
- #:use-module (gnu packages adns)
- #:use-module (gnu packages base)
- #:use-module (gnu packages compression)
- #:use-module (gnu packages gcc)
- #:use-module (gnu packages icu4c)
- #:use-module (gnu packages libevent)
- #:use-module (gnu packages linux)
- #:use-module (gnu packages perl)
- #:use-module (gnu packages pkg-config)
- #:use-module (gnu packages python)
- #:use-module (gnu packages tls)
- #:use-module (gnu packages web))
- (define-public node
- (package
- (name "node")
- (version "9.11.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://nodejs.org/dist/v" version
- "/node-v" version ".tar.gz"))
- (sha256
- (base32
- "1vjh9zvw7wkdz6b0l99ya7mqjk0l8lbg9isr1q8rxwp400dhkk32"))
- (modules '((guix build utils)))
- (snippet
- `(begin
- ;; Remove bundled software.
- (for-each delete-file-recursively
- '("deps/cares"
- "deps/http_parser"
- "deps/icu-small"
- "deps/nghttp2"
- "deps/openssl"
- "deps/uv"
- "deps/zlib"))
- (substitute* "Makefile"
- ;; Remove references to bundled software.
- (("deps/http_parser/http_parser.gyp") "")
- (("deps/uv/include/\\*.h") "")
- (("deps/uv/uv.gyp") "")
- (("deps/zlib/zlib.gyp") ""))
- #t))))
- (build-system gnu-build-system)
- (arguments
- ;; TODO: Purge the bundled copies from the source.
- '(#:configure-flags '("--shared-cares"
- "--shared-http-parser"
- "--shared-libuv"
- "--shared-nghttp2"
- "--shared-openssl"
- "--shared-zlib"
- "--without-snapshot"
- "--with-intl=system-icu")
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'patch-files
- (lambda* (#:key inputs #:allow-other-keys)
- ;; This phase is inherited by Node LTS, which does not have all
- ;; the files listed here. Use this helper for convenience.
- (define (delete-if-exists file)
- (if (file-exists? file)
- (delete-file file)
- '()))
- ;; Fix hardcoded /bin/sh references.
- (substitute* '("lib/child_process.js"
- "lib/internal/v8_prof_polyfill.js"
- "test/parallel/test-child-process-spawnsync-shell.js"
- "test/parallel/test-stdio-closed.js")
- (("'/bin/sh'")
- (string-append "'" (which "sh") "'")))
- ;; Fix hardcoded /usr/bin/env references.
- (substitute* '("test/parallel/test-child-process-default-options.js"
- "test/parallel/test-child-process-env.js"
- "test/parallel/test-child-process-exec-env.js")
- (("'/usr/bin/env'")
- (string-append "'" (which "env") "'")))
- ;; FIXME: These tests depend on being able to install eslint.
- ;; See https://github.com/nodejs/node/issues/17098.
- (for-each delete-if-exists
- '("test/parallel/test-eslint-alphabetize-errors.js"
- "test/parallel/test-eslint-buffer-constructor.js"
- "test/parallel/test-eslint-documented-errors.js"
- "test/parallel/test-eslint-inspector-check.js"))
- ;; FIXME: These tests fail in the build container, but they don't
- ;; seem to be indicative of real problems in practice.
- (for-each delete-if-exists
- '("test/async-hooks/test-ttywrap.readstream.js"
- "test/parallel/test-util-inspect.js"
- "test/parallel/test-v8-serdes.js"
- "test/parallel/test-dgram-membership.js"
- "test/parallel/test-dns-cancel-reverse-lookup.js"
- "test/parallel/test-dns-resolveany.js"
- "test/parallel/test-cluster-master-error.js"
- "test/parallel/test-cluster-master-kill.js"
- "test/parallel/test-net-listen-after-destroying-stdin.js"
- "test/parallel/test-npm-install.js"
- "test/sequential/test-child-process-emfile.js"
- "test/sequential/test-benchmark-child-process.js"
- "test/sequential/test-http-regr-gh-2928.js"))
- ;; These tests have an expiry date: they depend on the validity of
- ;; TLS certificates that are bundled with the source. We want this
- ;; package to be reproducible forever, so remove those.
- ;; TODO: Regenerate certs instead.
- (for-each delete-if-exists
- '("test/parallel/test-tls-passphrase.js"
- "test/parallel/test-tls-server-verify.js"))
- #t))
- (replace 'configure
- ;; Node's configure script is actually a python script, so we can't
- ;; run it with bash.
- (lambda* (#:key outputs (configure-flags '()) inputs
- #:allow-other-keys)
- (let* ((prefix (assoc-ref outputs "out"))
- (flags (cons (string-append "--prefix=" prefix)
- configure-flags)))
- (format #t "build directory: ~s~%" (getcwd))
- (format #t "configure flags: ~s~%" flags)
- ;; Node's configure script expects the CC environment variable to
- ;; be set.
- (setenv "CC" (string-append (assoc-ref inputs "gcc") "/bin/gcc"))
- (apply invoke
- (string-append (assoc-ref inputs "python")
- "/bin/python")
- "configure" flags))))
- (add-after 'patch-shebangs 'patch-npm-shebang
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((bindir (string-append (assoc-ref outputs "out")
- "/bin"))
- (npm (string-append bindir "/npm"))
- (target (readlink npm)))
- (with-directory-excursion bindir
- (patch-shebang target (list bindir))
- #t)))))))
- (native-inputs
- `(("python" ,python-2)
- ("perl" ,perl)
- ("pkg-config" ,pkg-config)
- ("procps" ,procps)
- ("util-linux" ,util-linux)
- ("which" ,which)))
- (native-search-paths
- (list (search-path-specification
- (variable "NODE_PATH")
- (files '("lib/node_modules")))))
- (inputs
- `(("c-ares" ,c-ares)
- ("http-parser" ,http-parser)
- ("icu4c" ,icu4c)
- ("libuv" ,libuv-1.19)
- ("nghttp2" ,nghttp2 "lib")
- ("openssl" ,openssl)
- ("zlib" ,zlib)))
- (synopsis "Evented I/O for V8 JavaScript")
- (description "Node.js is a platform built on Chrome's JavaScript runtime
- for easily building fast, scalable network applications. Node.js uses an
- event-driven, non-blocking I/O model that makes it lightweight and efficient,
- perfect for data-intensive real-time applications that run across distributed
- devices.")
- (home-page "https://nodejs.org/")
- (license expat)
- (properties '((timeout . 3600))))) ; 1 h
- (define-public node-lts
- (package
- (inherit node)
- (name "node-lts")
- (version "8.12.0")
- (source (origin
- (inherit (package-source node))
- (uri (string-append "https://nodejs.org/dist/v" version
- "/node-v" version ".tar.xz"))
- (sha256
- (base32
- "16j1rrxkhmvpcw689ndw1raql1gz4jqn7n82z55zn63c05cgz7as"))))))
|