microcom.scm 2.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2016 John Darrington <jmd@gnu.org>
  3. ;;;
  4. ;;; This file is part of GNU Guix.
  5. ;;;
  6. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  7. ;;; under the terms of the GNU General Public License as published by
  8. ;;; the Free Software Foundation; either version 3 of the License, or (at
  9. ;;; your option) any later version.
  10. ;;;
  11. ;;; GNU Guix is distributed in the hope that it will be useful, but
  12. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  13. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  14. ;;; GNU General Public License for more details.
  15. ;;;
  16. ;;; You should have received a copy of the GNU General Public License
  17. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  18. (define-module (gnu packages microcom)
  19. #:use-module (guix packages)
  20. #:use-module (guix licenses)
  21. #:use-module (guix git-download)
  22. #:use-module (guix download)
  23. #:use-module (gnu packages autotools)
  24. #:use-module (gnu packages readline)
  25. #:use-module (guix build-system gnu))
  26. (define-public microcom
  27. (package
  28. (name "microcom")
  29. (version "2016.01.09")
  30. (source (origin
  31. (method git-fetch)
  32. (uri (git-reference
  33. (url "https://git.pengutronix.de/git/tools/microcom.git")
  34. (commit "v2016.01.0")))
  35. (file-name (string-append name "-" version "-checkout"))
  36. (sha256
  37. (base32
  38. "080ci5589bpyy5kcl51csmvpw9zysify189hw6awx69pi3cjnxly"))))
  39. (build-system gnu-build-system)
  40. (inputs `(("readline" ,readline)))
  41. (native-inputs `(("automake" ,automake)
  42. ("autoconf" ,autoconf)))
  43. (home-page "http://git.pengutronix.de/?p=tools/microcom.git")
  44. (synopsis "Minimalistic serial line terminal program")
  45. (description "Microcom is a minimalistic terminal program for accessing
  46. devices via a serial connection. It features connection via RS232 serial
  47. interfaces (including setting of transfer rates) as well as in `telnetmode'
  48. as specified in rfc2217 and a (Linux specific) CAN mode.")
  49. (license gpl2+)))