acct.scm 1.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
  3. ;;;
  4. ;;; This file is part of GNU Guix.
  5. ;;;
  6. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  7. ;;; under the terms of the GNU General Public License as published by
  8. ;;; the Free Software Foundation; either version 3 of the License, or (at
  9. ;;; your option) any later version.
  10. ;;;
  11. ;;; GNU Guix is distributed in the hope that it will be useful, but
  12. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  13. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  14. ;;; GNU General Public License for more details.
  15. ;;;
  16. ;;; You should have received a copy of the GNU General Public License
  17. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  18. (define-module (gnu packages acct)
  19. #:use-module (guix licenses)
  20. #:use-module (guix packages)
  21. #:use-module (guix download)
  22. #:use-module (guix build-system gnu))
  23. (define-public acct
  24. (package
  25. (name "acct")
  26. (version "6.6.4")
  27. (source
  28. (origin
  29. (method url-fetch)
  30. (uri (string-append "mirror://gnu/acct/acct-"
  31. version ".tar.gz"))
  32. (sha256
  33. (base32
  34. "0gv6m8giazshvgpvwbng98chpas09myyfw1zr2y7hqxib0mvy5ac"))))
  35. (build-system gnu-build-system)
  36. (home-page "https://gnu.org/software/acct/")
  37. (synopsis "Standard login and process accounting utilities")
  38. (description
  39. "GNU acct provides a means for system administrators to determine
  40. system usage patterns. It provides information on, for example, connections,
  41. programs executed, and system resources used.")
  42. (license gpl3+)))