i3status-rust-0.22.0.ebuild 3.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197
  1. # Copyright 2020-2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. CRATES="
  5. aho-corasick-0.7.18
  6. assert_fs-1.0.7
  7. autocfg-1.1.0
  8. base64-0.13.0
  9. bitflags-1.3.2
  10. bstr-0.2.17
  11. byteorder-1.4.3
  12. cc-1.0.73
  13. cfg-if-1.0.0
  14. charset-0.1.3
  15. chrono-0.4.19
  16. chrono-tz-0.6.1
  17. chrono-tz-build-0.0.2
  18. clap-2.34.0
  19. crossbeam-channel-0.5.4
  20. crossbeam-utils-0.8.8
  21. curl-0.4.43
  22. curl-sys-0.4.53+curl-7.82.0
  23. darling-0.10.2
  24. darling_core-0.10.2
  25. darling_macro-0.10.2
  26. data-encoding-2.3.2
  27. dbus-0.9.5
  28. dbus-tree-0.9.2
  29. difflib-0.4.0
  30. dirs-next-2.0.0
  31. dirs-sys-next-0.1.2
  32. doc-comment-0.3.3
  33. either-1.6.1
  34. encoding_rs-0.8.31
  35. fastrand-1.7.0
  36. fnv-1.0.7
  37. from_variants-0.6.0
  38. from_variants_impl-0.6.0
  39. gethostname-0.2.3
  40. getrandom-0.2.6
  41. globset-0.4.8
  42. globwalk-0.8.1
  43. ident_case-1.0.1
  44. ignore-0.4.18
  45. inotify-0.10.0
  46. inotify-sys-0.1.5
  47. instant-0.1.12
  48. itertools-0.10.3
  49. itoa-1.0.1
  50. lazy_static-1.4.0
  51. libc-0.2.123
  52. libdbus-sys-0.2.2
  53. libpulse-binding-2.26.0
  54. libpulse-sys-1.19.3
  55. libsensors-sys-0.2.0
  56. libz-sys-1.1.5
  57. log-0.4.16
  58. maildir-0.6.1
  59. mailparse-0.13.8
  60. memchr-2.4.1
  61. memoffset-0.6.5
  62. neli-0.6.1
  63. neli-proc-macros-0.1.1
  64. neli-wifi-0.3.1
  65. nix-0.23.1
  66. notmuch-0.7.1
  67. num-derive-0.3.3
  68. num-integer-0.1.44
  69. num-traits-0.2.14
  70. once_cell-1.10.0
  71. openssl-probe-0.1.5
  72. openssl-sys-0.9.72
  73. parse-zoneinfo-0.3.0
  74. phf-0.10.1
  75. phf_codegen-0.10.0
  76. phf_generator-0.10.0
  77. phf_shared-0.10.0
  78. pkg-config-0.3.25
  79. ppv-lite86-0.2.16
  80. predicates-2.1.1
  81. predicates-core-1.0.3
  82. predicates-tree-1.0.5
  83. proc-macro2-1.0.37
  84. pure-rust-locales-0.5.6
  85. quote-1.0.18
  86. quoted_printable-0.4.5
  87. rand-0.8.5
  88. rand_chacha-0.3.1
  89. rand_core-0.6.3
  90. redox_syscall-0.2.13
  91. redox_users-0.4.3
  92. regex-1.5.5
  93. regex-syntax-0.6.25
  94. remove_dir_all-0.5.3
  95. ryu-1.0.9
  96. same-file-1.0.6
  97. schannel-0.1.19
  98. sensors-0.2.2
  99. serde-1.0.136
  100. serde_derive-1.0.136
  101. serde_json-1.0.79
  102. shellexpand-2.1.0
  103. signal-hook-0.3.13
  104. signal-hook-registry-1.4.0
  105. siphasher-0.3.10
  106. socket2-0.4.4
  107. strsim-0.9.3
  108. swayipc-3.0.0
  109. swayipc-types-1.0.1
  110. syn-1.0.91
  111. tempfile-3.3.0
  112. termtree-0.2.4
  113. textwrap-0.11.0
  114. thiserror-1.0.30
  115. thiserror-impl-1.0.30
  116. thread_local-1.1.4
  117. time-0.1.43
  118. toml-0.5.9
  119. uncased-0.9.6
  120. unicode-width-0.1.9
  121. unicode-xid-0.2.2
  122. vcpkg-0.2.15
  123. version_check-0.9.4
  124. walkdir-2.3.2
  125. wasi-0.10.2+wasi-snapshot-preview1
  126. winapi-0.3.9
  127. winapi-i686-pc-windows-gnu-0.4.0
  128. winapi-util-0.1.5
  129. winapi-x86_64-pc-windows-gnu-0.4.0
  130. "
  131. inherit cargo
  132. DESCRIPTION="A feature-rich and resource-friendly replacement for i3status, written in Rust."
  133. HOMEPAGE="https://github.com/greshake/i3status-rust/"
  134. SRC_URI="https://github.com/greshake/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
  135. $(cargo_crate_uris ${CRATES})"
  136. LICENSE="GPL-3"
  137. SLOT="0"
  138. KEYWORDS="~amd64 ~x86"
  139. IUSE="kdeconnect networkmanager man maildir notmuch pulseaudio profile"
  140. QA_FLAGS_IGNORED="usr/bin/i3status-rs"
  141. DEPEND="
  142. sys-apps/dbus
  143. media-sound/alsa-utils
  144. net-wireless/bluez
  145. net-misc/curl
  146. sys-apps/fakeroot
  147. kdeconnect? ( kde-misc/kdeconnect )
  148. sys-apps/lm-sensors
  149. networkmanager? ( net-misc/networkmanager )
  150. maildir? ( dev-ruby/maildir )
  151. notmuch? ( net-mail/notmuch )
  152. pulseaudio? ( media-sound/pulseaudio )
  153. profile? ( dev-util/google-perftools )
  154. net-analyzer/speedtest-cli
  155. sys-power/upower
  156. "
  157. RDEPEND="${DEPEND}"
  158. BDEPEND="
  159. >=virtual/rust-1.53.0
  160. "
  161. RESTRICT="mirror"
  162. src_unpack() {
  163. cargo_src_unpack
  164. mv "${S}/man" "${S}/man.bak" || die
  165. }
  166. src_configure() {
  167. export PKG_CONFIG_ALLOW_CROSS=1
  168. myfeatures=(
  169. $(usev notmuch)
  170. $(usev maildir)
  171. $(usex profile profiling '')
  172. $(usev pulseaudio)
  173. )
  174. cargo_src_configure --no-default-features
  175. }
  176. src_compile() {
  177. cargo_src_compile ${myfeatures:+--features "${myfeatures[*]}"}
  178. }
  179. src_install() {
  180. use man && doman "${S}/man.bak/i3status-rs.1"
  181. cargo_src_install ${myfeatures:+--features "${myfeatures[*]}"}
  182. insinto /usr/share/"${PN}"
  183. doins -r files/icons files/themes examples
  184. fperms 0755 /usr/share/${PN}
  185. }