fluidd-1.24.1.ebuild 968 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. HOMEPAGE="https://docs.fluidd.xyz"
  5. DESCRIPTION="A free and open-source Klipper web interface for managing your 3d printer."
  6. SRC_URI="https://github.com/fluidd-core/fluidd/releases/download/v${PV}/${PN}.zip -> ${P}.zip"
  7. KEYWORDS="amd64 arm64 arm x86 mips mipsel"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. IUSE=""
  11. BDEPEND="
  12. app-arch/unzip
  13. "
  14. RDEPEND="
  15. app-misc/moonraker
  16. www-servers/nginx
  17. "
  18. RESTRICT="mirror"
  19. S=${WORKDIR}
  20. src_compile() {
  21. :
  22. }
  23. src_install() {
  24. dodir /usr/share/${PN}
  25. cp -R . "${ED}"/usr/share/"${PN}" || die "Copy files failed"
  26. insinto /etc/klipper
  27. doins "${FILESDIR}/config.json"
  28. dosym ../../../etc/klipper/config.json /var/www/${PN}/config.json
  29. insinto /etc/nginx/conf.d
  30. doins "${FILESDIR}"/fluidd.conf "${FILESDIR}"/upstreams.conf "${FILESDIR}"/common_vars.conf
  31. }
  32. pkg_postinst() {
  33. echo
  34. elog "Adapt /etc/klipper/config.json to your needs"
  35. }