12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273 |
- # Copyright 1999-2024 Gentoo Authors
- # Distributed under the terms of the GNU General Public License v2
- EAPI=8
- inherit cmake-multilib toolchain-funcs
- Sparse_PV="7.6.0"
- Sparse_P="SuiteSparse-${Sparse_PV}"
- DESCRIPTION="Unsymmetric multifrontal sparse LU factorization library"
- HOMEPAGE="https://people.engr.tamu.edu/davis/suitesparse.html"
- SRC_URI="https://github.com/DrTimothyAldenDavis/SuiteSparse/archive/refs/tags/v${Sparse_PV}.tar.gz -> ${Sparse_P}.gh.tar.gz"
- LICENSE="GPL-2+"
- SLOT="0/6"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
- IUSE="debug doc +cholmod openmp static-libs test"
- RESTRICT="!test? ( test )"
- DEPEND=">=sci-libs/suitesparseconfig-${Sparse_PV}
- >=sci-libs/amd-3.3.1
- cholmod? ( >=sci-libs/cholmod-5.2.0:=[openmp?] )
- virtual/blas"
- RDEPEND="${DEPEND}"
- BDEPEND="doc? ( virtual/latex-base )"
- S="${WORKDIR}/${Sparse_P}/${PN^^}"
- pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
- }
- pkg_setup() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
- }
- multilib_src_configure() {
- # Fortran is only used to compile additional demo programs that can be tested.
- local mycmakeargs=(
- -DBUILD_STATIC_LIBS=$(usex static-libs)
- -DUMFPACK_USE_CHOLMOD=$(usex cholmod)
- -DSUITESPARSE_DEMOS=$(usex test)
- )
- cmake_src_configure
- }
- multilib_src_test() {
- # Run simple demo first
- # Other demo files have issues making them unsuitable for testing
- ./umfpack_simple || die "failed testing umfpack_simple"
- }
- multilib_src_install() {
- if use doc; then
- pushd "${S}/Doc"
- rm -rf *.pdf
- emake
- popd
- DOCS="${S}/Doc/*.pdf"
- fi
- cmake_src_install
- }
- multilib_src_install_all() {
- use doc && einstalldocs
- use !static-libs && ( find "${ED}" -name "*.a" -delete || die )
- # strip .la files
- find "${ED}" -name '*.la' -delete || die
- }
|