wlsunset-9999.ebuild 786 B

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. # Copyright 2021-2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit meson
  5. if [[ "${PV}" == 9999 ]]; then
  6. inherit git-r3
  7. EGIT_REPO_URI="https://github.com/kennylevinsen/wlsunset"
  8. else
  9. KEYWORDS="~amd64"
  10. SRC_URI="https://github.com/kennylevinsen/wlsunset/archive/${PV}.tar.gz -> ${P}.tar.gz"
  11. fi
  12. DESCRIPTION="Day/night gamma adjustments for Wayland"
  13. HOMEPAGE="https://sr.ht/~kennylevinsen/wlsunset/"
  14. IUSE="man"
  15. LICENSE="MIT"
  16. SLOT="0"
  17. RESTRICT="mirror"
  18. BDEPEND="
  19. dev-util/wayland-scanner
  20. man? ( app-text/scdoc )
  21. virtual/pkgconfig
  22. "
  23. RDEPEND="dev-libs/wayland"
  24. DEPEND="
  25. ${RDEPEND}
  26. dev-libs/wayland-protocols
  27. "
  28. src_configure() {
  29. local emesonargs=(
  30. "-Dwerror=false"
  31. $(meson_feature man man-pages)
  32. )
  33. meson_src_configure
  34. }