ulauncher-9999.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162
  1. # Copyright 1999-2023 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. PYTHON_COMPAT=( python3_{10,11} )
  5. MY_PN="Ulauncher"
  6. inherit distutils-r1
  7. DESCRIPTION="Application launcher for Linux on wayland"
  8. HOMEPAGE="https://ulauncher.io"
  9. if [[ ${PV} = *9999 ]]; then
  10. inherit git-r3
  11. EGIT_REPO_URI="https://github.com/${MY_PN}/${MY_PN}"
  12. EGIT_SUBMODULES=()
  13. EGIT_BRANCH="v6"
  14. KEYWORDS=""
  15. else
  16. SRC_URI="https://github.com/Ulauncher/Ulauncher/archive/v${PV}/${P}.tar.gz -> ${P}.tar.gz"
  17. KEYWORDS="~amd64 ~x86"
  18. S=${WORKDIR}/${MY_PN}-${PV}
  19. fi
  20. LICENSE="GPL-3"
  21. SLOT="0"
  22. KEYWORDS="~amd64"
  23. IUSE="doc test"
  24. REQUIRED_USE="${PYTHON_REQUIRED_USE}"
  25. RDEPEND="
  26. net-libs/webkit-gtk:6
  27. "
  28. BDEPEND="
  29. dev-libs/keybinder
  30. x11-libs/gtk+:3[wayland]
  31. >=x11-libs/libnotify-0.8.2
  32. x11-libs/gdk-pixbuf:2
  33. >=x11-misc/wmctrl-1.07-r3
  34. >=dev-python/pydbus-0.6.0
  35. >=dev-python/Levenshtein-0.21.0
  36. >=dev-python/pyinotify-0.9.6-r1
  37. >=dev-python/websocket-client-1.5.1
  38. >=dev-python/pyxdg-0.28
  39. dev-python/pygobject:3
  40. >=dev-python/pycairo-1.23.0
  41. x11-libs/libwnck:3
  42. "
  43. RESTRICT="
  44. mirror
  45. test ( test )
  46. "