pw-volume-9999.ebuild 1.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071
  1. # Copyright 2017-2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. CRATES="
  5. atty-0.2.14
  6. ansi_term-0.11.0
  7. anyhow-1.0.56
  8. bitflags-1.3.2
  9. cfg-if-1.0.0
  10. clap-2.33.3
  11. hermit-abi-0.1.19
  12. itoa-0.4.8
  13. libc-0.2.107
  14. proc-macro2-1.0.32
  15. proc-macro-error-1.0.4
  16. proc-macro-error-attr-1.0.4
  17. quote-1.0.10
  18. quoted_printable-0.4.5
  19. ryu-1.0.5
  20. serde-1.0.130
  21. serde_derive-1.0.130
  22. serde_json-1.0.70
  23. strsim-0.8.0
  24. syn-1.0.81
  25. test-case-2.1.0
  26. test-case-macros-2.1.0
  27. textwrap-0.11.0
  28. unicode-width-0.1.9
  29. unicode-xid-0.2.2
  30. vec_map-0.8.2
  31. version_check-0.9.4
  32. winapi-0.3.9
  33. winapi-i686-pc-windows-gnu-0.4.0
  34. winapi-util-0.1.5
  35. winapi-x86_64-pc-windows-gnu-0.4.0
  36. "
  37. inherit cargo
  38. DESCRIPTION="Basic interface to PipeWire volume controls"
  39. HOMEPAGE="https://github.com/smasher164/pw-volume"
  40. if [ ${PV} == "9999" ] ; then
  41. inherit git-r3
  42. EGIT_REPO_URI="https://github.com/smasher164/${PN}"
  43. else
  44. SRC_URI="https://github.com/smasher164/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
  45. $(cargo_crate_uris ${CRATES})"
  46. KEYWORDS="~amd64 ~arm64 ~arm ~ppc64 ~riscv ~x86"
  47. fi
  48. RESTRICT="mirror"
  49. src_unpack() {
  50. if [[ "${PV}" == *9999* ]]; then
  51. git-r3_src_unpack
  52. cargo_live_src_unpack
  53. else
  54. cargo_src_unpack
  55. fi
  56. }
  57. QA_FLAGS_IGNORED="usr/bin/${PN}"
  58. LICENSE="MIT"
  59. SLOT="0"
  60. #RDEPEND="gui-libs/"