eselect-nodejs-20230521.ebuild 599 B

12345678910111213141516171819202122232425
  1. # Copyright 1999-2024 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. DESCRIPTION="Manages the /usr/include/node symlink"
  5. HOMEPAGE="https://github.com/orsonteodoro/oiledmachine-overlay/tree/master/app-eselect/eselect-nodejs"
  6. LICENSE="GPL-2"
  7. KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86 ~amd64-linux ~x64-macos"
  8. SLOT="0"
  9. SRC_URI=""
  10. RESTRICT="fetch"
  11. src_unpack() {
  12. default
  13. mkdir -p "${S}" || die
  14. cp "${FILESDIR}/nodejs-${PVR}.eselect" "${S}/nodejs.eselect" || die
  15. }
  16. src_install() {
  17. insinto /usr/share/eselect/modules
  18. doins nodejs.eselect
  19. }