buildozer.spec 5.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193
  1. [app]
  2. # (str) Title of your application
  3. title = MediaGoblin
  4. # (str) Package name
  5. package.name = mediagoblin
  6. # (str) Package domain (needed for android/ios packaging)
  7. package.domain = com.sapientech
  8. # (str) Source code where the main.py live
  9. source.dir = .
  10. # (list) Source files to include (let empty to include all the files)
  11. source.include_exts = py,png,jpg,kv,atlas
  12. # (list) Source files to exclude (let empty to not exclude anything)
  13. #source.exclude_exts = spec
  14. # (list) List of directory to exclude (let empty to not exclude anything)
  15. #source.exclude_dirs = tests, bin
  16. # (list) List of exclusions using pattern matching
  17. #source.exclude_patterns = license,images/*/*.jpg
  18. # (str) Application versioning (method 1)
  19. version.regex = __version__ = ['"](.*)['"]
  20. version.filename = %(source.dir)s/main.py
  21. # (str) Application versioning (method 2)
  22. # version = 1.2.0
  23. # (list) Application requirements
  24. # comma seperated e.g. requirements = sqlite3,kivy
  25. # uncomment line below if current requirements fails
  26. requirements = kivy,python2,pypump,openssl,pyjnius,pytz
  27. # (str) Custom source folders for requirements
  28. # Sets custom source for any requirements with recipes
  29. # requirements.source.kivy = %(source.dir)s/submodules/kivy
  30. # (list) Garden requirements
  31. # garden_requirements = recycleview
  32. # (str) Presplash of the application
  33. presplash.filename = %(source.dir)s/images/logo.png
  34. # (str) Icon of the application
  35. icon.filename = %(source.dir)s/images/logo.png
  36. # (str) Supported orientation (one of landscape, portrait or all)
  37. orientation = portrait
  38. # (bool) Indicate if the application should be fullscreen or not
  39. fullscreen = False
  40. #
  41. # Android specific
  42. #
  43. # (list) Permissions
  44. android.permissions = INTERNET
  45. # (int) Android API to use
  46. android.api = 19
  47. # (int) Minimum API required (8 = Android 2.2 devices)
  48. android.minapi = 8
  49. # (int) Android SDK version to use
  50. android.sdk = 22
  51. # (str) Android NDK version to use
  52. #android.ndk = 9c
  53. # (bool) Use --private data storage (True) or --dir public storage (False)
  54. #android.private_storage = True
  55. # (str) Android NDK directory (if empty, it will be automatically downloaded.)
  56. #android.ndk_path =
  57. # (str) Android SDK directory (if empty, it will be automatically downloaded.)
  58. #android.sdk_path =
  59. # (str) python-for-android git clone directory (if empty, it will be automatically cloned from github)
  60. # android.p4a_dir = submodules/python-for-android
  61. # (list) python-for-android whitelist
  62. #android.p4a_whitelist =
  63. # (str) Android entry point, default is ok for Kivy-based app
  64. #android.entrypoint = org.renpy.android.PythonActivity
  65. # (list) List of Java .jar files to add to the libs so that pyjnius can access
  66. # their classes. Don't add jars that you do not need, since extra jars can slow
  67. # down the build process. Allows wildcards matching, for example:
  68. # OUYA-ODK/libs/*.jar
  69. #android.add_jars = foo.jar,bar.jar,path/to/more/*.jar
  70. # (list) List of Java files to add to the android project (can be java or a
  71. # directory containing the files)
  72. #android.add_src =
  73. # (str) python-for-android branch to use, if not master, useful to try
  74. # not yet merged features.
  75. #android.branch = master
  76. # (str) OUYA Console category. Should be one of GAME or APP
  77. # If you leave this blank, OUYA support will not be enabled
  78. #android.ouya.category = GAME
  79. # (str) Filename of OUYA Console icon. It must be a 732x412 png image.
  80. #android.ouya.icon.filename = %(source.dir)s/data/ouya_icon.png
  81. # (str) XML file to include as an intent filters in <activity> tag
  82. #android.manifest.intent_filters =
  83. # (list) Android additionnal libraries to copy into libs/armeabi
  84. #android.add_libs_armeabi = libs/android/*.so
  85. #android.add_libs_armeabi_v7a = libs/android-v7/*.so
  86. #android.add_libs_x86 = libs/android-x86/*.so
  87. #android.add_libs_mips = libs/android-mips/*.so
  88. # (bool) Indicate whether the screen should stay on
  89. # Don't forget to add the WAKE_LOCK permission if you set this to True
  90. #android.wakelock = False
  91. # (list) Android application meta-data to set (key=value format)
  92. #android.meta_data =
  93. # (list) Android library project to add (will be added in the
  94. # project.properties automatically.)
  95. #android.library_references =
  96. #
  97. # iOS specific
  98. #
  99. # (str) Name of the certificate to use for signing the debug version
  100. # Get a list of available identities: buildozer ios list_identities
  101. #ios.codesign.debug = "iPhone Developer: <lastname> <firstname> (<hexstring>)"
  102. # (str) Name of the certificate to use for signing the release version
  103. #ios.codesign.release = %(ios.codesign.debug)s
  104. [buildozer]
  105. # (int) Log level (0 = error only, 1 = info, 2 = debug (with command output))
  106. log_level = 1
  107. # (int) Display warning if buildozer is run as root (0 = False, 1 = True)
  108. warn_on_root = 1
  109. # -----------------------------------------------------------------------------
  110. # List as sections
  111. #
  112. # You can define all the "list" as [section:key].
  113. # Each line will be considered as a option to the list.
  114. # Let's take [app] / source.exclude_patterns.
  115. # Instead of doing:
  116. #
  117. #[app]
  118. #source.exclude_patterns = license,data/audio/*.wav,data/images/original/*
  119. #
  120. # This can be translated into:
  121. #
  122. #[app:source.exclude_patterns]
  123. #license
  124. #data/audio/*.wav
  125. #data/images/original/*
  126. #
  127. # -----------------------------------------------------------------------------
  128. # Profiles
  129. #
  130. # You can extend section / key with a profile
  131. # For example, you want to deploy a demo version of your application without
  132. # HD content. You could first change the title to add "(demo)" in the name
  133. # and extend the excluded directories to remove the HD content.
  134. #
  135. #[app@demo]
  136. #title = My Application (demo)
  137. #
  138. #[app:source.exclude_patterns@demo]
  139. #images/hd/*
  140. #
  141. # Then, invoke the command line with the "demo" profile:
  142. #
  143. #buildozer --profile demo android debug