PKGBUILD 1.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657
  1. # Maintainer: Luke Shumaker <lukeshu@parabola.nu>
  2. # Maintainer (Arch:lxpanel-gtk3): Balló György <ballogyor+arch at gmail dot com>
  3. # Contributor (Arch:lxpanel-gtk3): Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
  4. # Contributor (Arch:lxpanel-gtk3): Angel Velasquez <angvp@archlinux.org>
  5. # Contributor (Arch:lxpanel-gtk3): Juergen Hoetzel <juergen@archlinux.org>
  6. pkgname=lxpanel-gtk3
  7. pkgname+='-hidpi'
  8. _pkgname=lxpanel
  9. pkgver=0.10.0
  10. pkgrel=1
  11. pkgdesc='Lightweight X11 desktop panel for LXDE (GTK+ 3 version)'
  12. arch=('x86_64')
  13. arch+=('i686' 'armv7h')
  14. license=('GPL2')
  15. url='https://lxde.org/'
  16. groups=('lxde-gtk3')
  17. depends=('alsa-lib' 'curl' 'menu-cache' 'lxmenu-data' 'libfm-gtk3' 'libkeybinder3')
  18. makedepends=('intltool' 'docbook-xml' 'docbook-xsl' 'wireless_tools')
  19. optdepends=('wireless_tools: netstat plugin')
  20. conflicts=($_pkgname)
  21. source=(https://downloads.sourceforge.net/lxde/$_pkgname-$pkgver.tar.xz
  22. https://sourceforge.net/p/lxde/patches/_discuss/thread/0743e70d92/d1bb/attachment/0002-Support-HiDPI-on-GTK-3.patch)
  23. sha256sums=('4678cc8c5f1962376005ebf71ec1ee810115ac2e0e565f8d2e67dc12d01a3a7e'
  24. 'f847fd8d6a2e9616f519e1941740d33382d67d5db71c42e06c042eb242c90bc2')
  25. prepare() {
  26. cd $_pkgname-$pkgver
  27. patch -p1 -i ../0002-Support-HiDPI-on-GTK-3.patch
  28. # Disable pager plugin as it breaks panel layout with GTK+ 3
  29. # https://sourceforge.net/p/lxde/bugs/773/
  30. sed -i '/pager.c/d' plugins/Makefile.am
  31. sed -i '/STATIC_PAGER/d' src/private.h
  32. sed -i 's/libwnck-3.0//' configure.ac
  33. autoreconf -fi
  34. }
  35. build() {
  36. cd $_pkgname-$pkgver
  37. ./configure \
  38. --sysconfdir=/etc \
  39. --prefix=/usr \
  40. --enable-gtk3
  41. #https://bugzilla.gnome.org/show_bug.cgi?id=656231
  42. sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
  43. make
  44. }
  45. package() {
  46. cd $_pkgname-$pkgver
  47. make DESTDIR="$pkgdir" install
  48. }