PKGBUILD 844 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Maintainer: Luke Shumaker <lukeshu@sbcglobal.net>
  2. _pkgname=netctl-network-online
  3. pkgname=$_pkgname-git
  4. pkgver=20170128
  5. _gitver='commit=13f2ec3409d686cc81665e620c1559d3926a2e94'
  6. _tarver=20160101-at3
  7. pkgdesc="network-online.target integration for netctl"
  8. url="https://lukeshu.com/git/$_pkgname.git"
  9. license=('WTFPL2')
  10. provides=($_pkgname)
  11. conflicts=($_pkgname)
  12. pkgrel=1
  13. arch=('any')
  14. depends=('netctl')
  15. source=("https://repo.parabola.nu/other/~lukeshu/$_pkgname/$pkgname-$_tarver.tar.gz")
  16. md5sums=('32a20efd8fd1c31af18240466e20bb4a')
  17. mkdepends=('git')
  18. mksource=("$pkgname-$_tarver::git://git.lukeshu.com/$_pkgname.git#$_gitver")
  19. mkmd5sums=('SKIP')
  20. build() {
  21. cd "$srcdir/$pkgname-$_tarver"
  22. make sysconfdir=/etc prefix=/usr
  23. }
  24. package() {
  25. cd "$srcdir/$pkgname-$_tarver"
  26. make install sysconfdir=/etc prefix=/usr DESTDIR="$pkgdir"
  27. }