PKGBUILD 1003 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Maintainer (aur): Christopher Arndt <aur -at- chrisarndt -dot- de>
  2. # Contributor: bill-auger <bill-auger@programmer.net>
  3. pkgname=mhwaveedit
  4. pkgver=1.4.24
  5. pkgrel=1
  6. pkgdesc="A simple and fast GTK2 audio editor"
  7. arch=('armv7h' 'i686' 'x86_64')
  8. url=https://github.com/magnush/mhwaveedit
  9. license=('GPL')
  10. groups=('pro-audio')
  11. depends=(gtk2 hicolor-icon-theme libasound.so libjack.so libpulse.so libsamplerate.so
  12. libsndfile.so sdl)
  13. makedepends=(alsa-lib git ladspa libpulse libsamplerate libsndfile jack)
  14. source=(${pkgname}-${pkgver}.tar.gz::https://github.com/magnush/${pkgname}/archive/v${pkgver}.tar.gz)
  15. sha256sums=('a4115b3d18f3f038b08b2bf4ff599703b7ba69bc7ac510d5f7279b3f47ea57dd')
  16. build()
  17. {
  18. cd "${srcdir}"/${pkgname}-${pkgver}
  19. ./configure \
  20. --prefix=/usr \
  21. --with-double-samples \
  22. --without-arts \
  23. --without-esound \
  24. --without-oss
  25. make
  26. }
  27. package()
  28. {
  29. cd "${srcdir}"/${pkgname}-${pkgver}
  30. make DESTDIR="${pkgdir}"/ install
  31. }