PKGBUILD 2.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172
  1. # Maintainer (arch): Felix Yan <felixonmars@archlinux.org>
  2. # Maintainer (arch): Antonio Rojas <arojas@archlinux.org>
  3. # Contributor: Andrea Scarpino <andrea@archlinux.org>
  4. # Maintainer: Parabola Hackers <dev@lists.parabola.nu>
  5. # parabola changes and rationale:
  6. # - build without blacklisted 'fwupd'
  7. # - remove blacklisted 'fwupd' from optdepends
  8. pkgname=kinfocenter
  9. pkgver=6.0.2
  10. _dirver=$(echo $pkgver | cut -d. -f1-3)
  11. pkgrel=3
  12. pkgrel+=.parabola1
  13. pkgdesc='A utility that provides information about a computer system'
  14. arch=(x86_64)
  15. arch+=(armv7h i686)
  16. url='https://kde.org/plasma-desktop/'
  17. #license=(LGPL-2.0-or-later) # TODO:
  18. license=(LGPL)
  19. depends=(aha
  20. clinfo
  21. dmidecode
  22. gcc-libs
  23. glibc
  24. glu
  25. kauth
  26. kcmutils
  27. kconfig
  28. kcoreaddons
  29. kdeclarative
  30. ki18n
  31. kio
  32. kirigami
  33. kservice
  34. kwidgetsaddons
  35. libusb
  36. mesa-utils
  37. qt6-base
  38. qt6-declarative
  39. sh
  40. solid
  41. systemsettings
  42. vulkan-tools
  43. wayland-utils
  44. xorg-xdpyinfo)
  45. makedepends=(extra-cmake-modules
  46. fwupd
  47. kdoctools)
  48. makedepends=( ${makedepends[*]/fwupd/} ) # non-free
  49. groups=(plasma)
  50. source=(https://download.kde.org/stable/plasma/$_dirver/$pkgname-$pkgver.tar.xz{,.sig})
  51. sha256sums=('5d7d42990b7bdcaee776510fdbdf27e44b5bbe168c4e4e4d549f561e8fe2cb20'
  52. 'SKIP')
  53. validpgpkeys=('E0A3EB202F8E57528E13E72FD7574483BB57B18D' # Jonathan Esk-Riddell <jr@jriddell.org>
  54. '0AAC775BB6437A8D9AF7A3ACFE0784117FBCE11D' # Bhushan Shah <bshah@kde.org>
  55. 'D07BD8662C56CB291B316EB2F5675605C74E02CF' # David Edmundson <davidedmundson@kde.org>
  56. '1FA881591C26B276D7A5518EEAAF29B42A678C20') # Marco Martin <notmart@gmail.com>
  57. options=(debug)
  58. build() {
  59. cmake -B build -S $pkgname-$pkgver \
  60. -DBUILD_TESTING=OFF
  61. cmake --build build
  62. }
  63. package() {
  64. DESTDIR="$pkgdir" cmake --install build
  65. }