PKGBUILD 3.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091
  1. # Maintainer (arch): Maxime Gauduin <alucryd@archlinux.org>
  2. # Contributor: Stéphane Gaudreault <stephane@archlinux.org>
  3. # Contributor: BlackEagle <ike.devolder@gmail.com>
  4. # Contributor: Dany Martineau <dany.luc.martineau@gmail.com>
  5. # Contributor: André Silva <emulatorman@hyperbola.info>
  6. # Contributor: Márcio Silva <coadde@hyperbola.info>
  7. # Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
  8. # Contributor: Kete <kete@ninthfloor.org>
  9. # parabola changes and rationale:
  10. # - replaced nonfree nyancat artwork with moognu
  11. # - removed spotify support
  12. pkgname=clementine
  13. pkgver=1.4.0rc1+495+g10bf5dc17
  14. pkgrel=3
  15. pkgrel+=.parabola1
  16. pkgdesc='A modern music player and library organizer'
  17. pkgdesc+=', without nonfree artwork and Spotify support'
  18. url=https://www.clementine-player.org/
  19. license=(GPL)
  20. arch=(x86_64)
  21. arch+=(i686 armv7h)
  22. depends=(chromaprint gst-plugins-base-libs libcdio libgpod liblastfm-qt5 libmtp libmygpo-qt5
  23. taglib protobuf qt5-x11extras projectm alsa-lib libpulse crypto++ hicolor-icon-theme)
  24. makedepends=(boost cmake qt5-tools sparsehash)
  25. optdepends=(
  26. 'gst-plugins-base: "Base" plugin libraries'
  27. 'gst-plugins-good: "Good" plugin libraries'
  28. 'gst-plugins-bad: "Bad" plugin libraries'
  29. 'gst-plugins-ugly: "Ugly" plugin libraries'
  30. 'gst-libav: Libav plugin'
  31. 'gvfs: Various devices support'
  32. )
  33. source=("https://github.com/clementine-player/Clementine/releases/download/${pkgver//+/-}/$pkgname-${pkgver//+/-}.tar.xz")
  34. source+=(remove-nonfree-artwork-and-spotify.patch
  35. moognu.png)
  36. sha256sums=('b61c7051b6282af3a5717a4d9e755e1b53e08a04339c6eb4b6df77521606cc03')
  37. sha256sums+=('d9b19730e792e15d026cc4b89019be032c4c4843aace421df418b8111fc5e79f'
  38. 'c6918617769152f3617c61f721819e69d03f671b85760b11cfe45abd53955bc4')
  39. prepare() {
  40. sed -e 's|CRYPTOPP cryptopp|CRYPTOPP libcryptopp|' -i $pkgname-${pkgver//+/-}/CMakeLists.txt # Fix crypto++ detection
  41. mkdir -p build
  42. cd "$pkgname-${pkgver//+/-}"
  43. # remove nonfree artwork for the Nyan Cat plugin
  44. # https://labs.parabola.nu/issues/329
  45. rm -v data/nyancat.png
  46. # remove nonfree artwork and Spotify references
  47. patch -Np1 -i ../remove-nonfree-artwork-and-spotify.patch
  48. # remove Spotifyblob files
  49. rm -rv ext/{$pkgname-spotifyblob,lib${pkgname}-spotifyblob}
  50. # remove Spotify files
  51. rm -rv src/internet/spotify
  52. rm -v data/icons/svg/spotify.svg
  53. rm -v data/providers/{22x22,32x32,48x48}/spotify.png
  54. rm -v data/spotify-attribution.png
  55. rm -v data/clementine-spotify-public.pem
  56. rm -v cmake/SpotifyVersion.cmake
  57. rm -v data/schema/schema-30.sql
  58. rm -v src/globalsearch/spotifysearchprovider.{cpp,h}
  59. # move free Nyan Cat replacement mascot (MooGNU) to the source code
  60. # https://labs.parabola.nu/issues/329
  61. install -m644 -v ../moognu.png data
  62. # create an empty file because it's a dependency for Clementine
  63. touch data/schema/schema-30.sql
  64. }
  65. build() {
  66. cmake -B build -S $pkgname-${pkgver//+/-} \
  67. -DCMAKE_INSTALL_PREFIX=/usr \
  68. -DUSE_SYSTEM_PROJECTM=ON \
  69. -DUSE_SYSTEM_TAGLIB=ON
  70. cmake --build build
  71. }
  72. package() {
  73. DESTDIR="$pkgdir" cmake --install build
  74. }