PKGBUILD 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687
  1. # Maintainer (arch): Levente Polyak <anthraxx[at]archlinux[dot]org>
  2. # Maintainer (arch): Eric Bélanger <eric@archlinux.org>
  3. # Maintainer: Andreas Grapentin <andreas@grapentin.org>
  4. # Contributor: André Silva <emulatorman@hyperbola.info>
  5. # parabola changes and rationale:
  6. # - removed faac support
  7. pkgbase=avidemux
  8. pkgname=('avidemux-cli' 'avidemux-qt')
  9. pkgver=2.7.8
  10. pkgrel=2
  11. pkgrel+=.parabola1
  12. pkgdesc='Graphical tool to edit video (filter/re-encode/split)'
  13. pkgdesc+=', without nonfree faac support'
  14. url='http://fixounet.free.fr/avidemux/'
  15. arch=('x86_64')
  16. arch+=('i686' 'armv7h')
  17. license=('GPL2')
  18. makedepends=('cmake' 'libxslt' 'qt5-base' 'jack' 'libvorbis' 'libxv' 'opus' 'desktop-file-utils'
  19. 'alsa-lib' 'lame' 'xvidcore' 'faad2' 'x264' 'x265' 'libsamplerate'
  20. 'opencore-amr' 'yasm' 'mesa' 'libvpx' 'libpulse' 'libva' 'intltool' 'sqlite'
  21. 'libvdpau' 'libdca' 'fribidi' 'glu' 'qt5-tools' 'twolame' 'libfdk-aac' 'libass')
  22. options=('!emptydirs')
  23. source=(https://downloads.sourceforge.net/avidemux/avidemux_${pkgver}.tar.gz
  24. log.diff qt-5.15.diff)
  25. sha256sums=('628a404f521ff2812760700ae3e2aa78e5816b0ff3fb6fd05ac3e75248d97401'
  26. '8b751d137037f22fd4ae6750709014bcf61269a18f1c32e1a91f481285c807aa'
  27. '255a2446d493503dc237482f6fe26e2186f0ea0ef43ac9e17b8059fe232aad43')
  28. sha512sums=('d936eb005a8418b8f3081fce599cd04bb1a256bb7cb4bf50bf2ed876658881ca76b8c6f3805da9f05614eea44eaf2d53da0f802b28ce76e754b738f2682df031'
  29. 'bbae5b4a549113b12e728c4c0ac8c1c92a0b7500be8dcecc791c16c9a913406feaa9f7bc477985970a920d2df391cc9392457512d84b9c4b829981cc072f2b2e'
  30. 'ed78c2a3e4ede4fed1d3ea353c7dc350dc73050f76c8112cb24d97b3eda01f7c186d5db199f71f56953c5e5d8104de44dc0e84e1bfa01b6647c050c11fc375f2')
  31. prepare() {
  32. cd ${pkgbase}_${pkgver}
  33. patch -Np1 -i ../log.diff # don't hide the build output
  34. patch -Np1 -i ../qt-5.15.diff # fix build against Qt 5.15.0
  35. sed -i 's|../avidemux/qt4|../avidemux/qt4 -DLRELEASE_EXECUTABLE=/usr/bin/lrelease-qt5|' bootStrap.bash
  36. sed -e 's|0.19|1.0|' -i avidemux_plugins/ADM_videoFilters6/ass/CMakeLists.txt
  37. }
  38. build() {
  39. cd ${pkgbase}_${pkgver}
  40. bash bootStrap.bash --with-core --with-cli --with-plugins
  41. }
  42. package_avidemux-cli() {
  43. depends=('libxml2' 'fontconfig' 'sqlite' 'libvpx' 'libva' 'libvdpau')
  44. optdepends=('lame: for the corresponding audio encoder plugin'
  45. 'faad2: for the corresponding audio decoder plugin'
  46. 'opus: for the corresponding audio decoder plugin'
  47. 'opencore-amr: for the corresponding audio decoder plugin'
  48. 'jack: for the corresponding audio device plugin'
  49. 'libpulse: for the corresponding audio device plugin'
  50. 'x264: for the corresponding video encoder plugin'
  51. 'libx264: for the corresponding video encoder plugin'
  52. 'x265: for the corresponding video encoder plugin'
  53. 'xvidcore: for the corresponding video encoder plugin'
  54. 'qt5-base: for the QtScript scripting support'
  55. 'libdca: for the corresponding audio decoder plugin'
  56. 'twolame: for the corresponding audio decoder plugin'
  57. 'libass: for the corresponding video filter plugin'
  58. 'fribidi: for the corresponding video filter plugin')
  59. cd ${pkgbase}_${pkgver}
  60. make -C buildCli DESTDIR="${pkgdir}" install
  61. make -C buildCore DESTDIR="${pkgdir}" install
  62. make -C buildPluginsCLI DESTDIR="${pkgdir}" install
  63. make -C buildPluginsCommon DESTDIR="${pkgdir}" install
  64. install -Dm 644 avidemux_icon.png "${pkgdir}/usr/share/pixmaps/avidemux.png"
  65. install -Dm 644 man/avidemux.1 -t "${pkgdir}/usr/share/man/man1"
  66. }
  67. package_avidemux-qt() {
  68. pkgdesc='Graphical tool to edit video (filter/re-encode/split) - Qt GUI'
  69. pkgdesc+=', without nonfree faac support'
  70. depends=("avidemux-cli=${pkgver}" 'qt5-base' 'x264' 'x265' 'glu' 'libxv' 'desktop-file-utils')
  71. replaces=('avidemux-gtk')
  72. cd ${pkgbase}_${pkgver}
  73. make -C buildQt5 DESTDIR="${pkgdir}" install
  74. make -C buildPluginsQt5 DESTDIR="${pkgdir}" install
  75. }
  76. # vim: ts=2 sw=2 et: