PKGBUILD 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Maintainer (arch): Laurent Carlier <lordheavym@gmail.com>
  2. # Contributor: Andrea Scarpino <andrea@archlinux.org>
  3. # Contributor: mightyjaym <jmambrosino@gmail.com>
  4. # Contributor: moostik <mooostik_at_gmail.com>
  5. # Contributor: André Silva <emulatorman@hyperbola.info>
  6. # Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
  7. pkgname=audex
  8. pkgver=0.79+91+g9bb62f3
  9. pkgrel=2
  10. pkgrel+=.parabola1
  11. pkgdesc="A CDDA extraction tool with a ftp upload function for KDE"
  12. pkgdesc+=", without nonfree faac recommendation"
  13. arch=('x86_64')
  14. arch+=('i686' 'armv7h')
  15. url="https://userbase.kde.org/Audex"
  16. license=('GPL')
  17. replaces=("${pkgname}-libre" "${pkgname}-parabola")
  18. conflicts=("${pkgname}-libre" "${pkgname}-parabola")
  19. depends=('libkcddb' 'hicolor-icon-theme' 'kcmutils' 'qt5-script')
  20. makedepends=('extra-cmake-modules' 'git')
  21. optdepends=('vorbis-tools: OGG encoder'
  22. 'flac: FLAC encoder'
  23. 'lame: MP3 encoder')
  24. _commit=9bb62f34878ede3104802709c154b7b244925970 # master
  25. source=("git://git.kde.org/audex.git#commit=$_commit")
  26. md5sums=('SKIP')
  27. pkgver() {
  28. cd audex
  29. git describe --tags | sed -e 's/-/+/g' -e 's/v//'
  30. }
  31. build() {
  32. cd audex
  33. mkdir build
  34. cd build
  35. cmake ../
  36. make
  37. }
  38. package() {
  39. cd audex/build
  40. make DESTDIR="${pkgdir}" install
  41. }