PKGBUILD 1.9 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. # Maintainer (arch): Jaroslav Lichtblau <svetlemodry@archlinux.org>
  2. # Contributor: leif_thande <leif.thande@gmail.com>
  3. # Contributor: tranquility <trankas@gmail.com>
  4. # Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
  5. # Maintainer: Márcio Silva <coadde@hyperbola.info>
  6. # Contributor: André Silva <emulatorman@hyperbola.info>
  7. pkgname=atool
  8. pkgver=0.39.0
  9. pkgrel=6
  10. pkgrel+=.par1
  11. pkgdesc="A script for managing file archives of various types"
  12. pkgdesc+=", without nonfree unace and unrar support"
  13. arch=('any')
  14. url="http://www.nongnu.org/$pkgname/"
  15. license=('GPL3')
  16. depends=('file' 'perl')
  17. replaces=("$pkgname-libre")
  18. conflicts=("$pkgname-libre")
  19. optdepends=("bzip2: for using $pkgname with bzip2 compressed archives"
  20. "cpio: for using $pkgname with cpio archives"
  21. "gzip: for using $pkgname with gzip compressed archives"
  22. "lhasa: for using $pkgname with lha, lharc and similar archives"
  23. "xz: for using $pkgname with lzma compressed archives"
  24. "lzop: for using $pkgname with lzop compressed archives"
  25. "p7zip: for using $pkgname with 7z archives"
  26. "tar: for using $pkgname with tar archives"
  27. "zip: for using $pkgname for creating zip archives"
  28. "unzip: for using $pkgname for unpacking archives")
  29. source=(http://savannah.nongnu.org/download/$pkgname/$pkgname-$pkgver.tar.gz{,.sig}
  30. libre.patch)
  31. validpgpkeys=('4E6E6521EF300E30457D7AFB8AAAC30E7088EFCB') # Oskar Liljeblad <oskar@osk.mine.nu>
  32. sha256sums=('aaf60095884abb872e25f8e919a8a63d0dabaeca46faeba87d12812d6efc703b'
  33. 'SKIP'
  34. 'c9aa3c72e4c979d236dd659f16cc1eb6841f0860e6ef4d2c90f021d6e5aca578')
  35. prepare() {
  36. cd ${srcdir}/${pkgname}-${pkgver}
  37. # remove nonfree unace and unrar support
  38. patch -Np1 -i ../libre.patch
  39. }
  40. build() {
  41. cd "${srcdir}"/${pkgname}-${pkgver}
  42. ./configure --prefix=/usr --sysconfdir=/etc
  43. }
  44. package() {
  45. cd "${srcdir}"/${pkgname}-${pkgver}
  46. make DESTDIR="${pkgdir}" install
  47. }