PKGBUILD 3.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107
  1. # Maintainer: Luke Shumaker <lukeshu@parabola.nu>
  2. # Maintainer: David P. <megver83@parabola.nu>
  3. # Contributor: Joshua Ismael Haase Hernández (xihh) <hahj87@gmail.com>
  4. # Contributor: fauno <fauno@kiwwwi.com.ar>
  5. # Contributor: Márcio Silva <coadde@hyperbola.info>
  6. pkgbase=libretools
  7. pkgname=(libretools librelib gitget)
  8. pkgdesc="Programs for Parabola development"
  9. url="https://git.parabola.nu/packages/libretools.git/"
  10. license=('GPL3' 'GPL2')
  11. pkgver=20190907
  12. source=(https://repo.parabola.nu/other/$pkgname/$pkgname-$pkgver-nonsystemd.tar.gz{,.sig}
  13. "revert.patch::https://git.parabola.nu/packages/libretools.git/patch/?id=42cca853176c9ff23a5d2896f9b132630f034fb7"
  14. 0002-libremakepkg-pacman_5_2.patch)
  15. sha256sums=('c9bdc6f422234b6b260349e488266500756857bbb65079783aa5e997b6a2d410'
  16. 'SKIP'
  17. '108aa8bbfb1ffe96427540cd8f7788338883b08ad038b2ed426e93ac6c57e91b'
  18. '8986adf14a81b979b2ff4c4e3e76483115c146782e4ba30640649299f98355df')
  19. validpgpkeys=('99195DD3BB6FE10A2F36ED8445698744D4FFBFC9' # Luke Shumaker
  20. '6DB9C4B4F0D8C0DC432CF6E4227CA7C556B2BA78') # David P.
  21. pkgrel=1
  22. pkgrel+=.nonsystemd2
  23. arch=('any')
  24. makedepends=(ruby-ronn)
  25. checkdepends=(
  26. bash-bats git
  27. 'pacman>=5.1.1-1.parabola5' 'pacman<6.1'
  28. expac
  29. openssh
  30. rsync
  31. tokyocabinet
  32. )
  33. prepare() {
  34. cd "$srcdir/$pkgbase-$pkgver-nonsystemd"
  35. patch -N -p1 -i $srcdir/revert.patch
  36. patch -N -p1 -i $srcdir/0002-libremakepkg-pacman_5_2.patch
  37. }
  38. build() {
  39. cd "$srcdir/$pkgbase-$pkgver-nonsystemd"
  40. make
  41. }
  42. package_librelib() {
  43. pkgdesc="The shell library portion of libretools"
  44. license=(GPL2)
  45. conflicts=('xbs')
  46. optdepends=(
  47. 'libretools: for libreblacklist/blacklist.sh'
  48. 'wget: for libreblacklist/blacklist.sh'
  49. )
  50. cd "$srcdir/$pkgbase-$pkgver-nonsystemd"
  51. make install-librelib DESTDIR="$pkgdir"
  52. }
  53. package_gitget() {
  54. pkgdesc="A simple to use downloader for git URLs"
  55. license=(GPL2)
  56. depends=("librelib=$pkgver" git)
  57. provides=("libregit=$pkgver")
  58. conflicts=("libregit")
  59. replaces=("libregit")
  60. cd "$srcdir/$pkgbase-$pkgver-nonsystemd"
  61. make install-gitget DESTDIR="$pkgdir"
  62. }
  63. package_libretools() {
  64. backup=(etc/libretools.conf
  65. etc/libretools.d/chroot.conf
  66. etc/libretools.d/libredbdiff.conf
  67. etc/libretools.d/librefetch.conf)
  68. install=libretools.install
  69. conflicts=(devtools libretools-mips64el)
  70. replaces=(libretools-mips64el)
  71. depends=(
  72. "librelib=$pkgver"
  73. "gitget=$pkgver" # `createworkdir`
  74. 'pacman>=5.1.1-1.parabola5' 'pacman<6.1'
  75. arch-install-scripts # `mkarchroot` uses `pacstrap`
  76. binutils # `libremakepkg` uses `makepkg` uses `strip`
  77. expac # `libredbdiff`
  78. fakeroot # `libremakepkg` uses `makepkg` uses `fakeroot`
  79. make # `librefetch`
  80. openssh # `librerelease`
  81. rsync # `librerelease` and `makechrootpkg.sh`
  82. tokyocabinet # `toru`
  83. #namcap # Namcap is currently dissabled in libremakepkg :-(
  84. subversion # `diff-unfree`
  85. wget # `aur`, optdepend for librelib:`blacklist`
  86. )
  87. optdepends=(
  88. 'qemu-user-static-binfmt: To build ARM packages from x86'
  89. )
  90. cd "$srcdir/$pkgbase-$pkgver-nonsystemd"
  91. make install-libretools DESTDIR="$pkgdir"
  92. }