12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061 |
- # Maintainer: Sébastien Luttringer <seblu@archlinux.org>
- # Contributor: Allan McRae <allan@archlinux.org>
- # Contributor: Andreas Radke <andyrtr@archlinux.org>
- pkgname=file
- pkgver=5.38
- pkgrel=1
- pkgdesc='File type identification utility'
- arch=('x86_64')
- arch+=('armv7h' 'i686' 'ppc64le')
- license=('custom')
- groups=('base-devel')
- url='https://www.darwinsys.com/file/'
- depends=('glibc' 'zlib' 'xz' 'bzip2' 'libseccomp' 'libseccomp.so')
- provides=('libmagic.so')
- source=("ftp://ftp.astron.com/pub/$pkgname/$pkgname-$pkgver.tar.gz"{,.asc})
- validpgpkeys=('BE04995BA8F90ED0C0C176C471112AB16CB33B3A') # Christos Zoulas
- sha256sums=('593c2ffc2ab349c5aea0f55fedfe4d681737b6b62376a9b3ad1e77b2cc19fa34'
- 'SKIP')
- prepare() {
- cd $pkgname-$pkgver
- # apply patch from the source array (should be a pacman feature)
- local src
- for src in "${source[@]}"; do
- src="${src%%::*}"
- src="${src##*/}"
- [[ $src = *.patch ]] || continue
- msg2 "Applying patch $src..."
- patch -Np1 < "../$src"
- done
- }
- build() {
- cd $pkgname-$pkgver
- # Fix linking libmagic (vfork needs libpthread)
- CFLAGS+=" -pthread"
- ./configure \
- --prefix=/usr \
- --datadir=/usr/share/file \
- --enable-fsect-man5 \
- --enable-libseccomp
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
- make
- }
- check() {
- cd $pkgname-$pkgver
- make check
- }
- package() {
- cd $pkgname-$pkgver
- make DESTDIR="$pkgdir" install
- install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
- }
- # vim:set ts=2 sw=2 et:
|