1234567891011121314151617181920212223242526272829303132333435363738394041 |
- # Maintainer (aur): Christopher Arndt <aur -at- chrisarndt -dot- de>
- # Contributor: bill-auger <bill-auger@programmer.net>
- pkgname=mhwaveedit
- pkgver=1.4.24
- pkgrel=1
- pkgdesc="A simple and fast GTK2 audio editor"
- arch=('armv7h' 'i686' 'x86_64')
- url=https://github.com/magnush/mhwaveedit
- license=('GPL')
- groups=('pro-audio')
- depends=(gtk2 hicolor-icon-theme libasound.so libjack.so libpulse.so libsamplerate.so
- libsndfile.so sdl)
- makedepends=(alsa-lib git ladspa libpulse libsamplerate libsndfile jack)
- source=(${pkgname}-${pkgver}.tar.gz::https://github.com/magnush/${pkgname}/archive/v${pkgver}.tar.gz)
- sha256sums=('a4115b3d18f3f038b08b2bf4ff599703b7ba69bc7ac510d5f7279b3f47ea57dd')
- build()
- {
- cd "${srcdir}"/${pkgname}-${pkgver}
- ./configure \
- --prefix=/usr \
- --with-double-samples \
- --without-arts \
- --without-esound \
- --without-oss
- make
- }
- package()
- {
- cd "${srcdir}"/${pkgname}-${pkgver}
- make DESTDIR="${pkgdir}"/ install
- }
|