12345678910111213141516171819202122232425262728293031323334353637383940 |
- # SPDX-License-Identifier: CC0-1.0
- # Maintainer: Parabola Hackers <dev@lists.parabola.nu>
- # NOTE: This PKGBUILD does not need to be edited manually.
- # The package is normally built automatically by the auto-builder.
- # To generate a new package, simply push changes to blacklist.git.
- # If ${pkgname}-blacklist.txt is modified, the auto-builder will
- # replace $pkgver, $_srcver, and the checksum (updpkgsums),
- # build and publish the package, and commit the changes to abslibre.
- pkgname=your-freedom
- pkgver=20240521
- _srcver=65c07f43753523692ca4642b1a285d73a77c1210
- pkgrel=1
- pkgdesc="This meta-package conflicts with every known non-free Arch package"
- arch=(any)
- url=https://wiki.parabola.nu/Blacklist
- license=(custom:CCPL:zero)
- # license=('CCPL:zero') # TODO: NYI
- makedepends=(librelib)
- install=${pkgname}.install
- _srcname=${pkgname}-blacklist-${_srcver}.txt
- source=(${_srcname}::https://git.parabola.nu/blacklist.git/plain/blacklist.txt?id=${_srcver})
- sha256sums=('07f9c3202f65d57b659958ddc6c67805235eedd4ce74c445f248dd9d16b612c6')
- package()
- {
- # collect blacklisted package names as pacman conflicts,
- # also to be excluded by the repo importer, and rejected by libremakepkg
- conflicts=( $( libreblacklist normalize < ${_srcname} | \
- cut -d: -f1,2 | sed -n 's/:$//p' | sort -u ) )
- install -Dm644 ${_srcname} "${pkgdir}"/usr/share/doc/${pkgname}/blacklist.txt
- }
|